Opened 12 years ago

Closed 12 years ago

#1241 closed bug (fixed)

BTextView and BScrollView: - Scroll and resize window issue

Reported by: katisu Owned by: axeld
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/pre-alpha1
Keywords: Cc: katisu@…, axeld@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This currently appears to be a seperate issue, but may be related to ticket #1240. This was originally filed under ticket #1231 as an issue with the PCL6 driver, but after review appears to be related to Haiku's implementation of BTextView and/or BScrollView.

How to reproduce: When adding a PCL6 printer, an additional dialog shows up to select the protocol. If user scrolls the description text down for PCL 6 Protocol Class 1.1 and then resizes the dialog, the description text does not adjust vertically. The result is the top text is cut off and can not be reached without making the dialog smaller again.

Attachments (2)

Image2.png (15.0 KB ) - added by katisu 12 years ago.
Scroll and resize issue
scrollbar.diff (552 bytes ) - added by jackburton 12 years ago.

Download all attachments as: .zip

Change History (8)

by katisu, 12 years ago

Attachment: Image2.png added

Scroll and resize issue

comment:1 by jackburton, 12 years ago

Component: Servers/app_serverKits/Interface Kit
Owner: changed from axeld to jackburton

comment:2 by jackburton, 12 years ago

Status: newassigned

Should be fixed (as bug #1240) in hrev21207. Can you confirm ?

in reply to:  2 comment:3 by katisu, 12 years ago

Replying to jackburton:

Should be fixed (as bug #1240) in hrev21207. Can you confirm ?

#1240 is fixed. This one is not fix with hrev21207.

comment:4 by jackburton, 12 years ago

Cc: axeld@… added

BScrollBar::SetRange() isn't updating the value to fit the new ranges. The following patch fixes the problem. Though now Tracker is completely broken. Axel, can you have a look ?

by jackburton, 12 years ago

Attachment: scrollbar.diff added

comment:5 by axeld, 12 years ago

Owner: changed from jackburton to axeld
Status: assignednew

I'm looking into it; I'm pretty sure your change is correct, though - I'll just search for whatever is responsible for this. Tracker works still fine under BeOS.

comment:6 by axeld, 12 years ago

Resolution: fixed
Status: newclosed

Fixed in hrev21336. Indeed, the actual problem was caused by BView::ScrollBy() not taking the scroll range into account.

Note: See TracTickets for help on using tickets.