Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#12403 closed bug (duplicate)

Lenovo Ideapad z580 - Touchpad buttons don't work

Reported by: DFergFLA Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Drivers/Mouse/PS2 Version: R1/Development
Keywords: Cc:
Blocked By: #5179 Blocking:
Has a Patch: no Platform: All

Description

Both touchpad buttons on this laptop do not work. I can double tap the pad and get a "right" mouse click. But, I can't drag anything, I can't left click. This makes using Haiku very, very hard.

Just to be clear, if I double tap the middle of the touchpad I will get a "right" click. But if I try to use the right button I get nothing.

Attachments (3)

syslog (416.3 KB) - added by DFergFLA 4 years ago.
Syslog
listdev (2.3 KB) - added by DFergFLA 3 years ago.
listdev
listusb (698 bytes) - added by DFergFLA 3 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 4 years ago by DFergFLA

I am very sorry, I mixed up my right and left. It is the left click that I am getting, not the right.

comment:2 Changed 4 years ago by diver

As a general note - always mention Haiku revision. Also please attach your syslog.

comment:3 Changed 4 years ago by DFergFLA

Rev 46993

log attatched

Changed 4 years ago by DFergFLA

Attachment: syslog added

Syslog

comment:4 Changed 3 years ago by diver

Component: - GeneralDrivers/Mouse/PS2

comment:5 Changed 3 years ago by DFergFLA

I would like to ask about this ticket. I am very close to being able to use Haiku on this laptop. But the track buttons are still not working. Not being able to "right" click on anything is problematic when trying to use the OS.

comment:6 Changed 3 years ago by waddlesplash

Please attach a list of all devices (listdev & listusb) as well.

comment:7 Changed 3 years ago by DFergFLA

attaching listdev and listusb

Changed 3 years ago by DFergFLA

Attachment: listdev added

listdev

Changed 3 years ago by DFergFLA

Attachment: listusb added

comment:8 Changed 3 years ago by pulkomandy

@waddlesplash: the touchpad is a PS/2 device, as seen in the already posted syslog. So it doesn't show up in either listusb or listdev.

@DFergFLA: however, we do need some information on the hardware. Are there actual, separate physical buttons for right and left click on your machine, or are they part of the touchpad touch-sensitive area?

comment:9 Changed 3 years ago by DFergFLA

They are part of the touchpad.

Here is the manufactures website. I am unsure if this will be helpful, but it can't hurt. Again, thanks for looking.

http://shop.lenovo.com/us/en/laptops/ideapad/z-series/z580/

comment:10 Changed 3 years ago by pulkomandy

Blocked By: 5179 added
Resolution: duplicate
Status: newclosed

Ok, in that case it is probably a Synaptics Clickpad. Our driver has some trouble managing the physical buttons on these. I'm closing this as a duplicate of the (old) existing ticket. We may need to dive into Synaptics protocol specs again and see what can be done.

comment:11 Changed 3 years ago by DFergFLA

Ok, Thanks.

I hope someone can take a look at that old ticket. Haiku is very close to having an other laptop it works on.

Note: See TracTickets for help on using tickets.