Opened 4 years ago

Closed 4 years ago

#12499 closed bug (fixed)

In certain cases, class member variables aren't correctly exposed

Reported by: anevilyak Owned by: anevilyak
Priority: normal Milestone: Unscheduled
Component: Applications/Debugger Version: R1/Development
Keywords: Cc: jua
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

As seen in the crash report attached to #12478, the members for the clipped_alpha_mask class are missing. Currently, it isn't entirely clear why though, as trace output that was requested indicates that DwarfTypeFactory is in fact detecting and processing them, so their absence in the value node graph would seem to indicate a problem, though this could also simply be a quirk of gcc2's DWARF output (it has not yet been confirmed if the same problem is seen with DWARFv4 or not).

Change History (3)

comment:1 Changed 4 years ago by anevilyak

Cc: jua added

comment:2 Changed 4 years ago by anevilyak

Upon some further investigation, this behavior seems to be constrained to the crash report only, looking at the same stack frame interactively shows the correct graph. This seems to imply that something is going wrong in the report generator when recursively resolving the values to show.

comment:3 Changed 4 years ago by anevilyak

Resolution: fixed
Status: newclosed

Fixed in hrev49877.

Note: See TracTickets for help on using tickets.