Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#12524 closed bug (fixed)

New textfiles are write protected

Reported by: lelldorin Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

At the last Haiku nightly is download and installed (last hrev49600) all new textfiles are write protected.

Attachments (1)

new_text_file.png (23.7 KB) - added by un_spacyar 3 years ago.
retest in hrev50317 (x86_gcc2)

Download all attachments as: .zip

Change History (8)

comment:1 Changed 3 years ago by lelldorin

Was this Failure resolved?

comment:2 Changed 3 years ago by un_spacyar

I remember this issue from some time ago. However, I retested in hrev50317 (x86_gcc2) and the new textfiles created with the contextual menu (right click mouse over the Tracker), have write permissions for the owner.

Changed 3 years ago by un_spacyar

Attachment: new_text_file.png added

retest in hrev50317 (x86_gcc2)

comment:3 Changed 3 years ago by humdinger

Resolution: fixed
Status: newclosed

Works here too. Fixed then, I'd say.

comment:4 Changed 3 years ago by lelldorin

I have the same problem on hrev50443. I hear over Vision, that the problem is only on directly installed versions (nativ harddisk) and not using virtual machines.

comment:5 Changed 3 years ago by pulkomandy

That makes little sense. The point of virtual machines is that the OS running inside can't see the difference.

What matters is how your Haiku install was made (built yourself, or from a buildbot) and how it was updated since then. It is a known problem that some buildbots have wrongly set the umask and this leaks into the generated image, leading to files with incorrect permissions.

You can fix the Tracker template easily: chmod 666 config/settings/Tracker/Tracker\ New\ Templates/text\ file

comment:6 Changed 3 years ago by lelldorin

I download it from: http://download.haiku-os.org/nightly-images/x86_gcc2_hybrid/

The official way to get an image to install.

comment:7 Changed 3 years ago by pulkomandy

hrev50443 is commit http://cgit.haiku-os.org/haiku/commit/?id=0c1281a14f4ddf0482dfa4674e42156e3b57b198. The nightly (x86_gcc2) built from that is http://buildbot.haiku-os.org/builders/haiku-nightlies-x86_gcc2/builds/756 It comes from buildbot kallisti5-fedora01.

hrev49600 is too old, it is not stored anymore in the buildbot history.

Note: See TracTickets for help on using tickets.