Opened 4 years ago

Closed 3 years ago

#12546 closed bug (duplicate)

Webpositive cannot connect to Haiku Mailing Lists Archives

Reported by: vidrep Owned by: pulkomandy
Priority: normal Milestone: Unscheduled
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #12388
Has a Patch: no Platform: All

Description

Go to: Haiku Home page MEET THE COMMUNITY Mailing Lists Select any "Message archive" Webpositive never loads the page hrev49941 x86_gcc2

Change History (6)

comment:1 by pulkomandy, 4 years ago

How long did you wait? IIRC the page uses an external javascript file and the server for that can take a long time to reply (like, several minutes). There is still something wrong with how Web+ handles it (or maybe the request we send is not completely correct), because the problem isn't happening with other browsers.

comment:2 by vidrep, 4 years ago

I'm still seeing this with webkit 1.52 hrev50094 x86_gcc2

comment:3 by vidrep, 4 years ago

After the previous update, I decided to time how long it would take to load the pagein question. After waiting in excess of 15 minutes, it still had not loaded.

comment:4 by pulkomandy, 4 years ago

I did some debugging on this one. The main webpage seems to load fine, but then we get locked while loading one javascript file. The file is loaded over HTTPS and TLS negociation fails, probably because the website requires SNI (this is #12388). And apparently, the failure to load a script doesn't notify the browser that page loading failed, so it sits there waiting forever.

comment:5 by vidrep, 3 years ago

Tested with hrev50391 x86_64. The issue has been resolved and the ticket can be closed.

comment:6 by pulkomandy, 3 years ago

Blocking: 12388 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.