Opened 12 years ago

Closed 12 years ago

#1265 closed bug (invalid)

PS2 Mouse only works after killing the input server

Reported by: nielx Owned by: korli
Priority: normal Milestone: R1
Component: Servers/input_server Version: R1/pre-alpha1
Keywords: Cc: marcusoverhagen
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

With the current revision (hrev21338) I have problems with my mouse. Unfortunately, my previous revision was far back, so I can't give any indication on when it started. It did, however, work before.

Whenever Haiku is booted, my mouse does not move. The keyboard does work. When I kill the Input Server, the mouse starts to work.

I attached a syslog.

Attachments (1)

mouselog (114.6 KB ) - added by nielx 12 years ago.

Download all attachments as: .zip

Change History (5)

by nielx, 12 years ago

Attachment: mouselog added

comment:1 by korli, 12 years ago

Cc: marcusoverhagen added

Marcus, have you an idea about the syslog ps2 debug ? Is it normal ?

comment:2 by marcusoverhagen, 12 years ago

The output isn't what I expected.

The "ps2: active multiplexing not supported" should be followed by a call to ps2_command 0xae, but it isn't. This doesn't appears to be the current version of ps2 bus manager.

Can you please delete src/add-ons/kernel/bus_managers/ps2 and reload the source from SVN?

I also don't see any restart of the input server, only one keyboard_open and one mouse_open.

comment:3 by nielx, 12 years ago

I'll retry an svn update to see if anything went wrong, and I'll clear the partition.

Niels

comment:4 by nielx, 12 years ago

Resolution: invalid
Status: newclosed

Found out that installing Haiku on the partition failed. Haiku currently doesn't work, but I'm pretty sure that this problem is not relevant.

Closing. Sorry for using your time.

Note: See TracTickets for help on using tickets.