Opened 3 years ago

Closed 3 years ago

#12651 closed bug (duplicate)

Backgrounds app: update palette after modeswitch

Reported by: rudolfc Owned by: korli
Priority: normal Milestone: Unscheduled
Component: Preferences/Backgrounds Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by rudolfc)

The Backgrounds app does not update it's color palette after a modeswitch. It should do so however, also when it's dragged to another workspace. The palette should be updated if the new mode's colorspace differs from the previous one.

Change History (7)

comment:1 Changed 3 years ago by rudolfc

Component: - GeneralPreferences

comment:2 Changed 3 years ago by rudolfc

Description: modified (diff)

comment:3 Changed 3 years ago by diver

Component: PreferencesPreferences/Backgrounds
Owner: changed from nobody to korli

comment:4 Changed 3 years ago by rudolfc

Hmm, this bug was seen using a driver other than VESA: Looks like in VESA mode there's one -more- problem with this app: the palette isn't working right at all here. at least in other than 8-bit depth. strange.. maybe a problem with this app? or the VESA driver? The colorbars seem awfully off.. And of course doesn't update after modeswitches etc.

comment:5 Changed 3 years ago by pulkomandy

I'm not sure from your description, is this a duplicate of #8035 ?

comment:6 Changed 3 years ago by rudolfc

Ah, yes, indeed. But with a remark: also other colorspaces don't issue a redraw. So switch between any from: CMAP8, 15,16 and 32bit modes.. I am assuming the VESA driver (or my card BIOS) is te cause for the second mentioned probem just now.

comment:7 Changed 3 years ago by rudolfc

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.