Opened 3 years ago

Closed 2 years ago

#12650 closed bug (fixed)

64 bit MediaPlayer crashes on some AVI videos

Reported by: vidrep Owned by: stippi
Priority: normal Milestone: Unscheduled
Component: Applications/MediaPlayer Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #11617, #12508
Has a Patch: no Platform: x86-64

Description

hrev50095 x86_64 Some AVI format video files will cause MediaPlayer to crash These same files previously would play with ffmpeg 0.11.5 and stopped working with the update to ffmpeg 2.8 Attached is a short sample clip which will cause a crash

Attachments (1)

test.AVI (1.8 MB) - added by vidrep 3 years ago.

Download all attachments as: .zip

Change History (11)

Changed 3 years ago by vidrep

Attachment: test.AVI added

comment:1 Changed 3 years ago by vidrep

The sample clip attached will play normally on 32 bit Haiku.

comment:2 Changed 3 years ago by diver

Platform: Allx86-64

comment:3 Changed 3 years ago by vidrep

I tested hrev50101 x86_64 today using the new ffmpeg 3.0. It behaves in exactly the same manner as previous ffmpeg revisions.

comment:4 Changed 3 years ago by vidrep

This is a duplicate of one of my earlier tickets #11617. The older one can be closed and referenced.

comment:5 Changed 3 years ago by diver

Blocking: 11617 added

comment:6 Changed 3 years ago by korli

Blocking: 12508 added

comment:7 Changed 3 years ago by korli

This one crashes reliably :) What happens is: Video decoding fails because of #12731, which in turn triggers an assert in ffmpeg, calling abort(). The media extractor thread is still running and tries to call some BBufferIO method, which is already unloaded, thus the pure virtual method call. Whether resolving #12731 is enough to avoid crashing isn't sure.

comment:8 Changed 2 years ago by korli

Video decoding doesn't fail because of #12731: It seems we try to map B_YCbCr422 to a ffmpeg pixel format, but the mapping doesn't exist. B_YCbCr422 shouldn't be used as output colorspace when USE_SWS_FOR_COLOR_SPACE_CONVERSION is enabled. I think I'll make this change, and add some more checks or debugger() calls. This should also fix ogg files crashing on x86_64.

comment:9 Changed 2 years ago by vidrep

Confirmed working again on hrev51295 x86_64. Close the ticket! Thank you!

comment:10 Changed 2 years ago by korli

Resolution: fixed
Status: newclosed

A Mediaplayer thread seems to crash on closing, but that's a minor problem.

Note: See TracTickets for help on using tickets.