Opened 4 years ago

Closed 4 years ago

#12680 closed bug (fixed)

llvm-config throws error - Could not resolve symbol __tls_get_addr

Reported by: andrewz Owned by: korli
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

install llvm using HaikuDepot, run llvm-config, error results.

Change History (10)

comment:1 by korli, 4 years ago

Owner: changed from nobody to korli
Status: newassigned

Which hrev? Which llvm version? Which architecture?

comment:2 by andrewz, 4 years ago

hrev = 49933 arch = x86 llvm = ? can't tell because it won't run

comment:3 by korli, 4 years ago

Well, a hpkg provides llvm, it comes with a version.

comment:4 by andrewz, 4 years ago

Not sure which version for llvm, I installed and ran it yesterday. Pretty sure you can reproduce the problem by installing currently available version.

comment:5 by korli, 4 years ago

Packages are located in "/system/packages/". Just have a look there for the llvm's package name.

comment:6 by andrewz, 4 years ago

thanks, it is llvm_x86-3.5.2-1-x86_gcc2.hpkg

comment:7 by korli, 4 years ago

Platform: Allx86

Please confirm you run on architecture x86_gcc2. You wrote in comment:2 that you run on architecture x86...

comment:8 by diver, 4 years ago

I'm getting the same error on x86_gcc2.

comment:9 by korli, 4 years ago

Should be fixed with hrev50153. Please check.

comment:10 by diver, 4 years ago

Resolution: fixed
Status: assignedclosed

Works ok now, thanks!

Note: See TracTickets for help on using tickets.