Opened 3 years ago

Closed 2 years ago

#12707 closed bug (fixed)

64 bit MediaPlayer crashes on mp3 files

Reported by: vidrep Owned by: pulkomandy
Priority: normal Milestone: Unscheduled
Component: Applications/MediaPlayer Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #13116
Has a Patch: no Platform: x86-64

Description

hrev50191 x86_64 Attempting to play a mp3 file will cause a MediaPlayer crash MediaPlayer_log attached from CLI

Attachments (8)

MediaPlayer_log (727 bytes) - added by vidrep 3 years ago.
playfile.txt (521 bytes) - added by vidrep 3 years ago.
MediaPlayer.txt (665 bytes) - added by vidrep 3 years ago.
Streaming_mp3.txt (465 bytes) - added by vidrep 3 years ago.
Cuby & Blizzards - Let's make it.mp3 (2.0 MB) - added by vidrep 3 years ago.
VanillaFudge.mp3 (1.3 MB) - added by vidrep 3 years ago.
screenshot25.png (479.7 KB) - added by miqlas 3 years ago.
Works for me (TM)
01 Intro.mp3 (1.8 MB) - added by miqlas 3 years ago.
Problematic file

Change History (18)

Changed 3 years ago by vidrep

Attachment: MediaPlayer_log added

comment:1 Changed 3 years ago by korli

Please note that x86_64 has ffmpeg 3.0 (others don't). So this can actually be a regression, that would also appear when updating ffmpeg_x86 on x86_gcc2.

comment:2 Changed 3 years ago by vidrep

I am able to use MediaPlayer to stream mp3 without any issues. However, using MediaPlayer to open a mp3 on my HD will cause an immediate crash. I am able to open and play the same mp3 with "playfile" - no problem. I have attached a terminal log for each scenario.

Changed 3 years ago by vidrep

Attachment: playfile.txt added

Changed 3 years ago by vidrep

Attachment: MediaPlayer.txt added

Changed 3 years ago by vidrep

Attachment: Streaming_mp3.txt added

comment:3 Changed 3 years ago by korli

Blocking: 13116 added

comment:4 Changed 3 years ago by vidrep

Attached is a mp3 sample to test with.

Changed 3 years ago by vidrep

comment:5 Changed 3 years ago by korli

This file doesn't crash here on x86_64 hrev50778. The file is on a bfs USB key.

comment:6 Changed 3 years ago by vidrep

Just my luck - giving you a working mp3. I have attached one that I truncated with ffmpeg to get the size down to 30s. This one definitely does not work in MediaPlayer. Playfile does play it without any problem.

Changed 3 years ago by vidrep

Attachment: VanillaFudge.mp3 added

comment:7 Changed 3 years ago by miqlas

vidrep, it definetly works for me, see my attachement.

Changed 3 years ago by miqlas

Attachment: screenshot25.png added

Works for me (TM)

Changed 3 years ago by miqlas

Attachment: 01 Intro.mp3 added

Problematic file

comment:8 Changed 2 years ago by vidrep

Owner: changed from stippi to pulkomandy
Status: newassigned
Summary: mp3 files cause MediaPlayer crash on 64 bit builds64 bit MediaPlayer crashes on mp3 files

comment:9 Changed 2 years ago by diver

Platform: Allx86-64

comment:10 Changed 2 years ago by korli

Resolution: fixed
Status: assignedclosed

Fixed in hrev51306.

Note: See TracTickets for help on using tickets.