Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#13116 closed bug (duplicate)

MediaPlayer doesn't play some media files

Reported by: miqlas Owned by: stippi
Priority: normal Milestone: Unscheduled
Component: Applications/MediaPlayer Version: R1/Development
Keywords: Cc:
Blocked By: #12707 Blocking:
Has a Patch: no Platform: x86-64

Description

On latest Haiku x86_64 build i cannot play some mp3 files with MediaPlayer, it just shows up in Deskbar, then dissapears.

If i run MediaPlayer from Terminal to see, whats happening, it reports the following:

"Assertion desc failed at libswscale/swscale_internal.h:674"

Attachments (1)

0f2f83add1a04c739dde6e2481c5430f.png (398.2 KB) - added by miqlas 2 years ago.
Cover feature in MediaPlayer x64

Download all attachments as: .zip

Change History (9)

comment:1 Changed 2 years ago by miqlas

korli meant i should test the same media files with tried "playfile" in terminal. It should output information and play audio.

But i already tested the same files on x86 Haiku gcc2h, works perfectly, so it must be something with ffmpeg or mediaplayer on x68_64 Haiku.

If you wondering, what on earth doing swscale with mp3-s: The Haiku x86_64 build have cover feature, so if there is an embedded cover in the media file, it shows it automatically. See the attachment. I can be the root of the bug.

I can provide working and not working mp3 files, booth of them with embedded cover.

Last edited 2 years ago by miqlas (previous) (diff)

Changed 2 years ago by miqlas

Cover feature in MediaPlayer x64

comment:2 Changed 2 years ago by miqlas

It looks like it is the same as #12707

comment:3 Changed 2 years ago by korli

Blocked By: 12707 added
Resolution: duplicate
Status: newclosed

comment:4 Changed 2 years ago by vidrep

You can add tickets #12649, #12650, and #12654 as blockers as these tickets also address the inability of 64 bit to play "some media files".

comment:5 Changed 2 years ago by korli

Well #12707 doesn't have a sample file, would you mind sending me one?

comment:6 Changed 2 years ago by vidrep

korli, The samples you need are attached to the tickets referenced in my last comment. Perhaps these tickets should be assigned to someone other than stippi, since they appear to have been "forgotten".

comment:7 Changed 2 years ago by korli

@vidrep, no, only #12707 looks like this ticket, and it doesn't have a sample attached, hence my request (I don't have a lot of mp3s at hand, and I can't find to reproduce).

comment:8 Changed 2 years ago by vidrep

MP3 sample attached to ticket #12707.

Note: See TracTickets for help on using tickets.