Opened 3 years ago

Closed 3 years ago

#12749 closed bug (duplicate)

Crash while bootin' from usb

Reported by: tojoko Owned by: axeld
Priority: normal Milestone: Unscheduled
Component: Servers/app_server Version: R1/Development
Keywords: Cc:
Blocked By: #2539, #11619 Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

On Nokia Booklet 3G with hrev48309

Hardware as in https://dev.haiku-os.org/ticket/11947#no4

Attachments (4)

SYSLOG00.TXT (83.6 KB) - added by tojoko 3 years ago.
SYSLOG01.TXT (78.9 KB) - added by tojoko 3 years ago.
SYSLOG02.TXT (85.3 KB) - added by tojoko 3 years ago.
SYSLOG03.TXT (83.4 KB) - added by tojoko 3 years ago.

Download all attachments as: .zip

Change History (9)

Changed 3 years ago by tojoko

Attachment: SYSLOG00.TXT added

Changed 3 years ago by tojoko

Attachment: SYSLOG01.TXT added

Changed 3 years ago by tojoko

Attachment: SYSLOG02.TXT added

Changed 3 years ago by tojoko

Attachment: SYSLOG03.TXT added

comment:1 Changed 3 years ago by pulkomandy

Some description of the hardware would help (which graphics card, etc).

From the syslog:

1793	vm_soft_fault: va 0x0 not covered by area in address space
1794	vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0x0, ip 0x1afa805, write 1, user 1, thread 0x5f
1795	vm_page_fault: thread "picasso" (95) in team "app_server" (95) tried to write address 0x0, ip 0x1afa805 ("app_server_seg0ro" +0xfe805)
1796	debug_server: Thread 95 entered the debugger: Segment violation
1797	stack trace, current PC 0x1afa805  _CopyToFront__C11HWInterfacePUcUlllll + 0x119:
1798	  (0x72e7f018)  0x1af9fe7  _CopyBackToFront__11HWInterfaceR7BRegion + 0xbb
1799	  (0x72e7f088)  0x1ad2ff8  _CopyBackToFront__21AccelerantHWInterfaceR7BRegion + 0xfc
1800	  (0x72e7f0d8)  0x1af9e5a  CopyBackToFront__11HWInterfaceRC5BRect + 0x272
1801	  (0x72e7f188)  0x1af9bdc  Invalidate__11HWInterfaceRC5BRect + 0x58
1802	  (0x72e7f1b8)  0x1af705f  _CopyToFront__13DrawingEngineRC5BRect + 0x3b
1803	  (0x72e7f1e8)  0x1af32bf  FillRegion__13DrawingEngineR7BRegionRC9rgb_color + 0x13f
1804	  (0x72e7f258)  0x1a76134  _SetBackground__7DesktopR7BRegion + 0xe8
1805	  (0x72e7f2b8)  0x1a6eb9e  Init__7Desktop + 0x3a6
1806	  (0x72e7f348)  0x1a68a97  _CreateDesktop__9AppServerUiPCc + 0x87
1807	  (0x72e7f388)  0x1a68e7e  _DispatchMessage__9AppServerlRQ28BPrivate12LinkReceiver + 0x116
1808	  (0x72e7f3f8)  0x1a83ff4  _MessageLooper__13MessageLooper + 0xec
1809	  (0x72e7f538)  0x1a84040  _message_thread__13MessageLooperPv + 0x28
1810	  (0x72e7f568)  0x1a68a05  RunLooper__9AppServer + 0x3d
1811	  (0x72e7f5a8)  0x1a69013  main + 0x93
1812	  (0x72e7f5d8)  0x1a67bcf  _start + 0x5b
1813	  (0x72e7f608)  0x204aab2  runtime_loader + 0x132
1814	consoled: error -2 starting console.

but also:

1985	Could not initialize graphics output. Exiting.
1986	usb_disk: operation 0x35 failed at the SCSI level
1987	usb_disk: request_sense: key: 0x05; asc: 0x24; ascq: 0x00; Invalid field in CDB
1988	usb_disk: unhandled ioctl 10101
1989	usb_disk: operation 0x35 failed at the SCSI level
1990	usb_disk: request_sense: key: 0x05; asc: 0x24; ascq: 0x00; Invalid field in CDB
1991	usb_disk: operation 0x35 failed at the SCSI level
1992	usb_disk: request_sense: key: 0x05; asc: 0x24; ascq: 0x00; Invalid field in CDB

Not sure if these are related, there is an app_server crash and USB mass storage errors.

comment:2 Changed 3 years ago by diver

Component: - GeneralServers/app_server
Description: modified (diff)
Owner: changed from nobody to axeld
Platform: x86All

Might be a dupe of #2539

comment:3 Changed 3 years ago by pulkomandy

And the USB errors are probably from #11619. The last comments there suggest disabling ACPI in the boot menu to get USB working on this hardware.

Last edited 3 years ago by pulkomandy (previous) (diff)

comment:4 Changed 3 years ago by tojoko

i can not reconstruct the original problem any more, since hrev48309 is and is the last version that runs on the nokia booklet 3g.

i did have trouble with one usb stick not able to make bootable (with any os i tried so far) at all as well as havin' problems with later nightly builds, but that is covered in

https://dev.haiku-os.org/ticket/11947

i think, so please close this ticket here.

comment:5 Changed 3 years ago by pulkomandy

Blocked By: 2539, 11619 added
Resolution: duplicate
Status: newclosed

Thanks, closing as duplicate of the 2 others then.

Note: See TracTickets for help on using tickets.