Opened 3 years ago

Closed 3 years ago

Last modified 2 years ago

#12797 closed bug (invalid)

When I run checkfs I always get "[n] blocks could be freed"

Reported by: Giova84 Owned by: axeld
Priority: normal Milestone: Unscheduled
Component: File Systems/BFS Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Since i upgraded from hrev50141 to hrev50326, I noticed a strange behaviour with checkfs: every time that I run this command I always get "60127 blocks could be freed" (I could be wrong about "60127" but I can recall that was a great number), So i reinitialized my bfs partition and I installed over to the freshly reinitialized partition, my whole backup (my backup disk relies on another BFS partition on the same disk and such partition is healty.)

However, since I restored my system, I got again the same message about [n] blocks could be freed:

checkfs -c /boot

5200 nodes checked, 0 blocks not allocated, 0 blocks already set, 906 blocks could be freed

Every time that I run checkfs (with or without "c" flag) I always get, again, "906 blocks could be freed" I never see any other error; if I look at the syslog, in facts, I don't see any "bad data" message.

However I attach my syslog (I removed the optical drive due the ticket:12634, because due this bug the syslog was filled with the same message).

Attachments (1)

syslog (312.9 KB) - added by Giova84 3 years ago.

Download all attachments as: .zip

Change History (4)

Changed 3 years ago by Giova84

Attachment: syslog added

comment:1 Changed 3 years ago by Giova84

Since I upgraded to hrev50336, I no longer see this issue. Maybe there was some package corrupted or something similar?

If the owner of this ticket (axeld) thinks that could only been an occasional trouble, feel free to close this ticket as invalid.

comment:2 Changed 3 years ago by axeld

Resolution: invalid
Status: newclosed

Since the syslog doesn't contain anything useful, I'm closing this ticket -- if the issue comes up again, please tell.

comment:3 Changed 2 years ago by Giova84

Hi Axel, here and there (means that currently I rarely see such issue) this issue comes up again, but less compared to the past. I noticed that easily occurs when I install and uninstall packages, or when i write and then delete a lot of files on the disk; the "[n] blocks is usually a great number, now, when occurs.

Note: See TracTickets for help on using tickets.