Opened 4 years ago

Last modified 6 months ago

#12876 new bug

network performance degrades over time

Reported by: pulkomandy Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Network & Internet Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

I'm currently using my machine as a build slave to test the package build infrastructure. This means rather long uptimes (ideally several days).

Haiku seems to be quite stable, however, the network access becomes slower and slower over time, up to a point where everything seems to timeout and I have to reboot the computer.

I'm not sure what the problem is or how to investigate.

This is a wireless connection which makes it difficult to spy the traffic on the wire.

device Network controller [2|80|0]
  vendor 8086: Intel Corporation
  device 008a: Centrino Wireless-N 1030 [Rainbow Peak]

Wifi-N is disabled at boot using ifconfig, as it isn't working with this device.

Attachments (1)

partial_syslog (72.1 KB ) - added by TmTFx 14 months ago.

Download all attachments as: .zip

Change History (9)

comment:1 by vidrep, 4 years ago

I am also experiencing a network slowdown over a period of time, much as you have described. In my case, I am using a wired connection and must reset the modem/router to restore the performance.

Actiontec V1000H xDSL modem/wireless router/internet gateway

device Network controller (Ethernet controller) [2|0|0]

vendor 8086: Intel Corporation device 10ef: 82578DM Gigabit Network Connection

comment:2 by axeld, 4 years ago

Is this still reproducible? At least I could imagine that mmlr's DMA alignment fixes could have an impact on such issues.

comment:3 by pulkomandy, 4 years ago

Yes, I still run into this problem. I have some more precise information as I continue to watch for it. It seems that what becomes slow is opening of new connections. I suspect some problem in TCP handshake or similar. Eventually, it is so slow that it times out, and no connection can be opened. But even in that state, where I can't download anything with wget, I can still use Vision as long as its sockets to IRC servers stay open.

comment:4 by nzimmermann, 3 years ago

I experience the same problems with rtl81xx on bare metal.

Yesterday I started rsync transer from macOS -> Haiku, copying ~30.000 files. I left it unattended, and when I wanted to issue another git clone from a terminal, I got only ~ 30 KiB/s, which went up to ~600 KiB/s after a reboot.

I don't know what could be done to debug this though - I'm a Haiku newbie :-)

comment:5 by waddlesplash, 2 years ago

Hmm, I wonder if this is related to #11836?

comment:6 by TmTFx, 14 months ago

still happens to me on a rtl81xx + atheroswifi I normally have both networks connected, after some time I experienced this bug (slowdown and several pachet loss on a ping to a lan peer) so I disabled the wifi, routed the gateway again on the lan, then it worked again... after some downloads it happened again. I turned off lan, turned on wifi but no wifi networks found, so turned on again lan, reset the route gateway and it worked again (no need to say that apps that are downloading something and stucked there, and browser pages should be killed and restarted)

by TmTFx, 14 months ago

Attachment: partial_syslog added

comment:7 by ambroff, 6 months ago

I started looking at this today. I'm able to easily reproduce it on my real hardware installations over ethernet as well as in KVM. I found some performance issues in the tcp addon I've noted in #15886, but there is still some problem outside of that.

comment:8 by waddlesplash, 6 months ago

There used to be a bug where the TCP window size would continually decrease for no apparent reason until it was like 1 byte or something like that. I don't remember if we fixed that or not, but it should be pretty evident from a packet capture if it's still the case.

Note: See TracTickets for help on using tickets.