Opened 3 years ago

#12882 new bug

BeConverter (an old BeOS app) doesn't work on Haiku

Reported by: Giova84 Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Applications Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

From my BeOS-Machine i grabbed the app "BeConverter" (BeConverter is a BeOS native, multi-threaded unit of measure conversion tool.)

When I attempt to start this app on Haiku, the icon of the app will just appear in the Deskbar and from ProcessController I can see that this app will peg one core of my cpu, nothing else will happen: no errors and no alert; I also tried to start the app from the Terminal, but no output is displayed.

However I tried with the following command to see if something is displayed in the syslog when I launch the app.

Output of

tail -f /var/log/syslog


KERN: Last message repeated 10 times.
KERN: libnetwork.so running in R5 compatibility mode.
KERN: bfs: bfs_access:1520: Permission denied
KERN: Last message repeated 19 times.
KERN: Last message repeated 20 times.

All that I can do for now is to provide a zip archive which contains this application: http://softwaredepot.altervista.org/beos/BeConverter.zip

Change History (0)

Note: See TracTickets for help on using tickets.