Opened 3 years ago

Closed 3 years ago

#12935 closed bug (fixed)

Radeon HD5450 no VGA output (regression)

Reported by: vidrep Owned by: kallisti5
Priority: normal Milestone: Unscheduled
Component: Drivers/Graphics/radeon_hd Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev50523 x86_gcc2 ATI Radeon HD5450 with VGA, DVI, HDMI DVI is working (1680x1050@59.9Hz) VGA black screen (on-screen error message about unsupported video mode) attached Radeon_HD5450_listdev attached Radeon_HD5450_VGA (grep syslog radeon_hd)

DVI and VGA output are both verified working on Alpha 4.1 partition (same PC)

Attachments (4)

Radeon_HD5450_listdev (383 bytes ) - added by vidrep 3 years ago.
Radeon_HD5450_VGA (12.7 KB ) - added by vidrep 3 years ago.
Radeon_HD5450_VGA_a4 (38.7 KB ) - added by vidrep 3 years ago.
Dell_error.JPG (1.5 MB ) - added by vidrep 3 years ago.

Download all attachments as: .zip

Change History (12)

by vidrep, 3 years ago

Attachment: Radeon_HD5450_listdev added

by vidrep, 3 years ago

Attachment: Radeon_HD5450_VGA added

comment:1 by vidrep, 3 years ago

I have attached a copy of the alpha 4 syslog gep radeon_hd (Radeon_HD5450_VGA_a4)

by vidrep, 3 years ago

Attachment: Radeon_HD5450_VGA_a4 added

comment:2 by vidrep, 3 years ago

I have attached a photo of the Dell monitor error message (Dell_error.JPG)

by vidrep, 3 years ago

Attachment: Dell_error.JPG added

comment:3 by kallisti5, 3 years ago

Your card is doing some weird crap.

126     KERN: radeon_hd: detect_displays: found EDID data on connector 1
127	KERN: radeon_hd: detect_displays: connector 1 has digital EDID and is not a analog encoder.
128	KERN: radeon_hd: init_registers, registers for ATI chipset Cedar crt #0 loaded
129	KERN: radeon_hd: detect_displays: bit-banging ddc for EDID on connector 2
130	KERN: radeon_hd: connector_read_edid: found edid monitor on connector #2
131	KERN: radeon_hd: detect_displays: found EDID data on connector 2
132	KERN: radeon_hd: detect_displays: Warning: monitor on connector 2 has false digital EDID flag and unloaded analog encoder!
133	KERN: radeon_hd: init_registers, registers for ATI chipset Cedar crt #1 loaded
134	KERN: radeon_hd: Currently detected monitors===============
135	KERN: radeon_hd: Display #0 attached = true
136	KERN: radeon_hd:  + connector ID:   1
137	KERN: radeon_hd:  + connector type: DVI-I (Digital and Analog)
138	KERN: radeon_hd:  + encoder type:   TMDS
139	KERN: radeon_hd:  + limits: Vert Min/Max: 56/75
140	KERN: radeon_hd:  + limits: Horz Min/Max: 30/83
141	KERN: radeon_hd: Display #1 attached = true
142	KERN: radeon_hd:  + connector ID:   2
143	KERN: radeon_hd:  + connector type: DVI-I (Digital and Analog)
144	KERN: radeon_hd:  + encoder type:   TV DAC
145	KERN: radeon_hd:  + limits: Vert Min/Max: 56/75
146	KERN: radeon_hd:  + limits: Horz Min/Max: 30/83
147	KERN: radeon_hd: ==========================================

It looks like your card takes the DVI-I connector on the GPU (which carries TMDS and DAC (analog and digital channels on DVI-I devices)) and splits it into two physical connectors. A VGA connector and DVI-D connector (i'm guessing?)

I need some more information here:

  • Are you using any kind of DVI -> VGA adapters?
  • How many ports are exposed on your card.
  • Is this some kind of embedded GPU, or a physcial PCIe card?

You also mention that the monitor is connected over VGA, however the EDID data on the LCD display is reporting a digital connector.

comment:4 by kallisti5, 3 years ago

Actually, I had that backwards.

The first connector sees a digital monitor and finds a digital EDID. (which is legit and makes it look like a valid attached digital monitor over TMDS).

The second analog connector sees a valid analog EDID, however the card reports the encoder is unloaded (no display detected reading the analog channels)

If you have a bunch of monitors attached, try detaching all but the VGA and reboot. Haiku's app server doesn't support multiple monitors at this time.

comment:5 by vidrep, 3 years ago

Only one monitor and only one cable attached at a time (DVI or VGA). Everything works as it should booting alpha 4.

comment:6 by vidrep, 3 years ago

I can log onto IRC if you want. Let me know.

comment:7 by vidrep, 3 years ago

Tested again today using hrev50544 x86_gcc2. The VGA connector is now working. I tested the HDMI connecter as well, and found that the video is slightly overscanned and no audio. You can close this ticket (I'll create another for the HDMI issue).

comment:8 by humdinger, 3 years ago

Resolution: fixed
Status: newclosed

Closing ticket, as requested. Thanks for following up on it!

Note: See TracTickets for help on using tickets.