Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#12959 closed bug (invalid)

Confusing pkgman interaction

Reported by: axeld Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Applications/Command Line Tools Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When I update Haiku via pkgman update, the following text is shown:

Continue? [yes/no] (yes) : 
*** please enter 'yes' or 'no'

The "(yes)" Usually means that it's the default, and that I just have to press enter to continue.

Continue? [yes/no] (yes) : y

And even if it demanded a "yes" or "no", it will happily accept a "y", too.

Change History (11)

comment:1 Changed 3 years ago by humdinger

Not a bug, but intentional convenience, IIRC. It used to be "Continue? [y/n]". To make it more user friendly it was rephrased to be more like plain English. The old one-letter answers were kept for convenience. As it's very unlikely to enter a "y" if you really meant to enter a "n", I think it's OK as it is now.

comment:2 Changed 3 years ago by vidrep

See closed ticket #11260 for the original issue.

comment:3 Changed 3 years ago by pulkomandy

Well, either the "(yes)" should be removed, or just pressing enter should be accepted as a "yes". I would go with accepting just enter, just like we would if this was a graphical app and the same request was shown in a window. Having to type y + enter is a bit annoying for such a simple operation (and mostly harmless, since you can rollback to an older state if things go wrong anyway).

comment:4 Changed 3 years ago by vidrep

Often times when doing a pkgman full-sync, there will installed packages built from souces in haikuporter, that it will try to revision down. I like having the option to say "no" and just do a pkgman update in those cases.

comment:5 Changed 3 years ago by pulkomandy

Yes, saying "no" should be an option of course.

The thing is, either the message should be:

Continue? [yes/no]:

And the user will have to type "y" or "n" or "yes" or "no" to continue.

OR, the message stays as it is:

Continue? [yes/no] (yes) :

In that case, just pressing "enter" does the same as "y" or "yes". It is still possible to enter "n" or "no".

comment:6 in reply to:  5 Changed 3 years ago by humdinger

Replying to pulkomandy:

Continue? [yes/no] (yes) :

In that case, just pressing "enter" does the same as "y" or "yes". It is still possible to enter "n" or "no".

That's exactly how it behaves right now. Am I misunderstanding the issue?

comment:7 Changed 3 years ago by pulkomandy

If I read Axel's bug report correctly, pressing enter led to a *** please enter 'yes' or 'no', and adding an 'y' was required?

comment:8 Changed 3 years ago by humdinger

Nope. At least with hrev50531, it behaves like your second suggestion: the enter key behaves like typing "y" or "yes".

Last edited 3 years ago by humdinger (previous) (diff)

comment:9 Changed 3 years ago by axeld

I just pressed "enter", and it did come up with that response, so yes, Adrien did understand the report correctly :-) I just updated an older install of Haiku (from February), and there it worked okay (still with y/n). However, I can't be absolutely sure, though, that I didn't accidentally press some invisible key before the "enter". I can't test again right now, though, until a new release comes along :-)

comment:10 in reply to:  9 Changed 3 years ago by humdinger

Resolution: invalid
Status: newclosed

Replying to axeld:

However, I can't be absolutely sure, though, that I didn't accidentally press some invisible key before the "enter".

I had a slightly older hrev that I could experiment on. It really does work as expected, and I think your hypothesis of having something put in accidentally before hitting Enter is probably correct.

Let's close the ticket until someone can reproduce the issue.

comment:11 Changed 3 years ago by axeld

Yup, seems I was just dumb: updating now worked as expected.

Note: See TracTickets for help on using tickets.