Opened 12 years ago

Closed 12 years ago

#1312 closed bug (fixed)

[Menu] You need to have a valid app_server connection first!

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Kits/Application Kit Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

203: DEBUGGER: You need to have a valid app_server connection first! debug_server: Thread 203 entered the debugger: Debugger call: `You need to have a valid app_server connection first!' stack trace, current PC 0xffff0102 :

(0x7003fa0c) 0x2c9e23 Q28BPrivate13AppServerLink + 0x73 (0x7003fa3c) 0x2f09c0 _CleanUp7BBitmap + 0x48 (0x7003fa7c) 0x2eeac2 _._7BBitmap + 0x5e (0x7003faac) 0x206ef0 _._14BitmapMenuItem + 0x4c (0x7003fadc) 0x3268eb RemoveItems5BMenullP9BMenuItemb + 0x1bf (0x7003fb1c) 0x32444e RemoveItems5BMenullb + 0x32 (0x7003fb5c) 0x3233f0 _._5BMenu + 0x48 (0x7003fb9c) 0x328f1a _._8BMenuBar + 0x5e (0x7003fbcc) 0x20991f _._7MenuBar + 0x23 (0x7003fbfc) 0x36dcef _._5BView + 0x67 (0x7003fc2c) 0x36dcef _._5BView + 0x67 (0x7003fc5c) 0x3784e7 _._7BWindow + 0xe7 (0x7003fc8c) 0x20a717 _._10MenuWindow + 0x23 (0x7003fcbc) 0x2d0dc2 Quit7BLooper + 0xde (0x7003fcec) 0x378bf6 Quit7BWindow + 0xc6 (0x7003fd1c) 0x2d2407 _QuitRequested7BLooperP8BMessage + 0x107 (0x7003fd9c) 0x2d0946 DispatchMessage7BLooperP8BMessageP8BHandler + 0x46 (0x7003fdcc) 0x37b099 DispatchMessage7BWindowP8BMessageP8BHandler + 0x1391 (0x7003ff1c) 0x37e590 task_looper7BWindow + 0x270 (0x7003ff7c) 0x2d1e73 _task0_7BLooperPv + 0x3f (0x7003ffac) 0x4c874c _get_next_team_info + 0x5c (closest symbol)

Change History (4)

comment:1 Changed 12 years ago by jackburton

How do I reproduce this ?

comment:2 Changed 12 years ago by stippi

It might have to do with the recent changes to the window quitting loop. I also noticed a similar bug when closing NetPositive windows.

comment:3 Changed 12 years ago by jackburton

Component: - PreferencesKits/Application Kit

Reassigning, as it's an app kit bug.

comment:4 Changed 12 years ago by axeld

Resolution: fixed
Status: newclosed

This has been closed since some time - it was a bug in the application's window quit loop (_WindowAt() IIRC).

Note: See TracTickets for help on using tickets.