Opened 12 years ago

Closed 11 years ago

#1311 closed bug (fixed)

[FileTypes] freeze on MediaPlayer start

Reported by: diver Owned by: bonefish
Priority: normal Milestone: R1/alpha1
Component: Servers/registrar Version: R1/pre-alpha1
Keywords: Cc: marcusoverhagen
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

FileTypes could freeze on MediaPlayer start. It's not always reproducible, but i managed to freeze it 10 times already playing a little with FileTypes before starting MediaPlayer. Tested on linux in vmware with hrev21673.

Change History (9)

comment:1 Changed 12 years ago by diver

Ok, this is how i could always reproduce it: *boot Haiku *start FileTypes from Leaf menu *expand audio *select AC3 from the list *start MediaPlayer from terminal

comment:2 Changed 12 years ago by axeld

Milestone: R1R1/alpha

comment:3 Changed 12 years ago by diver

Tested more and it appears that you can't launch apps until MediaPlayer will not be killed, after that all apps that you launched in that frozen state will popup on screen. Tested with hrev22537 under vmware in linux.

comment:4 Changed 11 years ago by stippi

I followed the procedure both in VMWare and on real hardware, but I cannot reproduce this bug. Everything behaves fine.

comment:5 Changed 11 years ago by diver

Tested with hrev22730 in vmware server in ubuntu 7.10 and still could easy reproduce FileTypes freeze.

comment:6 Changed 11 years ago by modeenf

Tested on hrev23050 looks like MediaPlayer want to add some more filetypes and that the FileTypes app looks this some how.

tested divers steps to reproduce it I could only reproduce it the first time MediaPlayer was stared on the vmware image not after the changes was made.

comment:7 Changed 11 years ago by marcusoverhagen

Cc: marcusoverhagen added

comment:8 Changed 11 years ago by stippi

Component: - Preferences/FileTypesServers/registrar
Owner: changed from axeld to bonefish

I think, the bug should be in the Registrar. Something with notifications of mime database changes. In any case, a bug in FileTypes should not prevent other apps from starting. Another possible cause is the Registrar not receiving a reply message where it should (causing it to stall, then the bug could be in the application kit), but I have not looked at the code yet.

comment:9 Changed 11 years ago by mmlr

Resolution: fixed
Status: newclosed

Should be fixed in hrev23423.

Note: See TracTickets for help on using tickets.