Opened 3 years ago

Closed 2 months ago

#13152 closed bug (fixed)

[8086:2a02] Live-CD intel_extreme graphics driver no longer recognizes i965GM

Reported by: joergn_1 Owned by: pulkomandy
Priority: normal Milestone: R1/beta2
Component: Drivers/Graphics/intel_extreme/9xx Version: R1/Development
Keywords: Cc: PulkoMandy
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

The latest nightlies gives a blank screen on my notebook HP6910p. I bother to find out when the changes took place in the hrevs no longer supporting my notebook graphic card: The last working one with the correct resolution of 1280x800 was hrev50483, starting with hrev50533 i got a blank screen by booting with the live-CD. As of the time i tested the latest hrev70796 with the same result.

I've made txt files for the output of listdev, listimage and a copy of the syslog of all three tested hrevs: 50483 latest working, 50533 something must have changed, 50796 latest nightly as of the time of my tests.

Attachments (1)

divHREVSlistdev-listimages-syslogs.tar.gz (81.8 KB ) - added by joergn_1 3 years ago.
6 txt files of different hrevs with listimage, listdev and a copy of syslog

Download all attachments as: .zip

Change History (11)

by joergn_1, 3 years ago

6 txt files of different hrevs with listimage, listdev and a copy of syslog

comment:2 by pulkomandy, 14 months ago

Milestone: UnscheduledR1/beta2

comment:3 by waddlesplash, 8 months ago

Please retest after hrev53040.

comment:4 by kallisti5, 2 months ago

Does anyone have this hardware to test on a recent hrev?

comment:5 by luroh, 2 months ago

Keywords: graphics driver Intel i965GM removed
Summary: Live-CD intel.extreme graphics driver no longer recognizes i965GM[8086:2a02] Live-CD intel_extreme graphics driver no longer recognizes i965GM

I might have access to a 2510p, will check.

comment:6 by luroh, 2 months ago

Note to self: found two 2510p but no HP charger. Buy HP charger.

comment:7 by pulkomandy, 2 months ago

Both new syslogs you included are apparently with the intel accelerant disabled: the driver finds the device, but then is never requested to initialize it. To debug this we need a syslog with the accelerant actually trying to drive the video card.

Last edited 2 months ago by pulkomandy (previous) (diff)

comment:8 by pulkomandy, 2 months ago

Component: Drivers/Graphics/intel_extremeDrivers/Graphics/intel_extreme/9xx
Owner: changed from kallisti5 to pulkomandy

comment:9 by luroh, 2 months ago

hrev50657, gcc2h - indeed doesn't work, display all garbled.

hrev53541, gcc2h - works fine.

I suggest we close this one as fixed.

comment:10 by pulkomandy, 2 months ago

Resolution: fixed
Status: newclosed

Thanks for testing!

Note: See TracTickets for help on using tickets.