Opened 4 years ago

Closed 14 months ago

Last modified 3 months ago

#13159 closed bug (fixed)

Some LibreOffice's unit tests crash in __pthread_key_call_destructors

Reported by: KapiX Owned by: nobody
Priority: normal Milestone: R1/beta2
Component: System/runtime_loader Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #14234
Platform: All

Description

As in title.

Archive: http://haiku.kacperkasper.pl/repro_editeng_borderline.zip

Commandline: cppunittester libtest_editeng_borderline.so

Report attached.

cppunittester source: https://github.com/KapiX/libreoffice_core/blob/haiku/sal/cppunittester/cppunittester.cxx

Attachments (3)

cppunittester-9704-debug-08-01-2017-03-56-13.report (6.5 KB ) - added by KapiX 4 years ago.
LibreOffice-14425-debug-06-08-2018-19-34-53.report (63.5 KB ) - added by roiredxsoto 2 years ago.
LibreOffice Debug Log
vlc-2.2.8.zip (1.7 MB ) - added by diver 23 months ago.

Download all attachments as: .zip

Change History (16)

comment:1 by KapiX, 4 years ago

hrev50794 gcc5h

comment:2 by diver, 3 years ago

Component: - GeneralSystem/POSIX

comment:3 by diver, 3 years ago

Same with vlc-cache-gen which is used during vlc build.

comment:4 by KapiX, 2 years ago

Component: System/POSIXSystem/runtime_loader

I did some debugging during November coding sprint and I found out that __pthread_key_call_destructors tries to call destructors from glib. The issue is that when it's called (at application exit) glib is already unloaded (perhaps it was unloaded earlier) but its destructors were not called when that happened. It looks like runtime_loader issue.

comment:5 by diver, 2 years ago

LibreOffice crashes at exit with the same trace. korli fixed similar bug #5271 in hrev35098. korli, could you please take a look?

comment:6 by korli, 2 years ago

This bug needs a smaller testcase.

comment:7 by waddlesplash, 2 years ago

Blocking: 14234 added

by roiredxsoto, 2 years ago

LibreOffice Debug Log

comment:8 by roiredxsoto, 2 years ago

Hello everyone,

I just run into the same/similar issue:

  • Launch LibreOffice for the first time after power up pc -> LibreOffice crashes
  • Launch LibreOffice a second, third... Nth time -> LibreOffice starts "fine", can work on the document, crashes on quit

It does not matter which LibreOffice app is started, be it Writer, Calc, Draw...

Thanks a lot. Regards, RR

by diver, 23 months ago

Attachment: vlc-2.2.8.zip added

comment:9 by diver, 23 months ago

Attached binary reproduces the crash.

comment:10 by diver, 23 months ago

vlc-cache-gen binary crashes while processing libfluidsynth and libass vlc plugins. All other plugins are ok.

comment:11 by waddlesplash, 14 months ago

This needs to be retested following hrev53150.

comment:12 by diver, 14 months ago

Resolution: fixed
Status: newclosed

I haven't tested LibreOffice case yet, but both vlc-cache-gen and QMPlay2 don't crash anymore. Assuming fixed. Thanks!

comment:13 by nielx, 3 months ago

Milestone: UnscheduledR1/beta2

Assign tickets with status=closed and resolution=fixed within the R1/beta2 development window to the R1/beta2 Milestone

Note: See TracTickets for help on using tickets.