Opened 12 years ago

Closed 11 years ago

#1322 closed bug (fixed)

vm_soft_fault: va 0xdeadbeef not covered by area in address space

Reported by: jonas.kirilla Owned by: axeld
Priority: critical Milestone: R1/alpha1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Running this line in one or more Terminals

while (true); do times > /dev/null; done

sometimes crashes.

It may take a while, more than 5 minutes on my 2GHz real hardware, and sometimes it doesn't happen unless one does other things like selecting/copying text in the busy Terminal, fiddling with ProcessController, opening the Haiku menu or something.

The crash output seems to differ between running a single terminal and when running in multiple Terminals concurrently.

See attached zip with 4 KDLs.

Attachments (1)

deadbeef.zip (27.1 KB) - added by jonas.kirilla 12 years ago.

Download all attachments as: .zip

Change History (8)

Changed 12 years ago by jonas.kirilla

Attachment: deadbeef.zip added

comment:1 Changed 12 years ago by axeld

Component: SystemSystem/Kernel
Priority: normalcritical

Thank you, that's very helpful!

comment:2 Changed 12 years ago by bonefish

BTW, please don't zip serial debugs/syslogs. That's just unhandy, since people have to download and unzip the archive first instead of being able to look at them directly in the browser.

comment:3 in reply to:  2 Changed 12 years ago by jonas.kirilla

Sorry. I'll try to remember this.

Perhaps the Admin Team could discuss and publish a short FAQ on how to use the bug tracker. I'm sure pet peeves would be easy to list. ;)

comment:4 Changed 12 years ago by axeld

Milestone: R1R1/alpha

comment:5 Changed 11 years ago by axeld

I can't reproduce it here at all (I've got 3 Terminals running for more than 1 hour now). I only see that semaphores and memory is leaked; looks like the vm_cache references are not maintained correctly in some cases. Can you still reproduce this bug on your hardware?

comment:6 Changed 11 years ago by jonas.kirilla

No, it doesn't seem to happen anymore.

comment:7 Changed 11 years ago by axeld

Resolution: fixed
Status: newclosed

Thanks for the update!

Note: See TracTickets for help on using tickets.