Opened 2 years ago

Closed 2 years ago

#13233 closed bug (fixed)

Some pages on the new site randomly throw a "Bad data" error and fail to load in WebPositive

Reported by: waddlesplash Owned by: pulkomandy
Priority: normal Milestone: Unscheduled
Component: Kits/Network Kit Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Works in other browsers, even on Haiku, so I'm assuming this is a libbnetapi issue.

Nothing in Web+ stdout which gives any hints as to what the issue is.

Change History (4)

comment:1 Changed 2 years ago by waddlesplash

Owner: changed from axeld to pulkomandy
Status: newassigned

comment:2 Changed 2 years ago by pulkomandy

netlify is sending us broken HTTP.

On redirects, they set the header:

Content-Encoding: gzip

And the payload is:

Redirecting to /community/\r\n

Obviously, this is not a valid gzip stream. Hence it is rejected by libnetapi.

You do not see the problem in other browsers because they completely ignore the redirects. But because of a race condition in our webkit network backend, this doesn't quite work for us.

I will fix the race condition, but it would still be nice to remove that header in cases where the content isn't actually gzip'ed.

comment:3 Changed 2 years ago by waddlesplash

Reported to Netlify.

comment:4 Changed 2 years ago by pulkomandy

Resolution: fixed
Status: assignedclosed

Well the race condition is fixed, so no more visible issues on our side. Closing.

Note: See TracTickets for help on using tickets.