Opened 3 years ago

Closed 3 years ago

#13257 closed task (no change required)

No multiprozessor support for Sandybridge?

Reported by: bruno Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Hello all,

I use a Intel Core I5 2500K CPU 3.3 GHz 64-Bit system. Nightly build hrev 50878.

I don't get multiprocessor support! Only one Core is showing up.

Some time ago it was working... Do I have to turn it on somewhere?At boot maybe?

Ingo... (i think he is maintaining the multiprocessor support) has disabled it some time ago... is it on and running now?

Attachments (2)

syslog (160.4 KB ) - added by bruno 3 years ago.
listdev (3.5 KB ) - added by bruno 3 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 by pulkomandy, 3 years ago

Milestone: R1/beta1R1

Multi-processor is working fine for me and many others (including HyperThreading). It is enabled by default.

Please read the instructions on making a bug report: https://dev.haiku-os.org/wiki/ReportingBugs In particular:

  • Do not assign tickets to "beta1". It is up to the devs to decide what to include there.
  • Please include a syslog

Also make sure the problem isn't elsewhere, like maybe your BIOS has a setting for this? Does it work in other operating systems? Which version of Haiku are you running? x86_64? gcc2? gcc5?

comment:2 by bruno, 3 years ago

I use Haiku hrev.50887 x86_32 gcc2 build. Booting from CD.

Running on Intel Core I5 2500K CPU 3.3 GHz 64-Bit system.(Maybe I have to try the Haiku 64Bit Version Gcc2?!

by bruno, 3 years ago

Attachment: syslog added

by bruno, 3 years ago

Attachment: listdev added

comment:3 by diver, 3 years ago

smp: using ACPI to detect MP configuration
smp: Failed to find MADT!
smp_mp_probe: entry base 0x9fc00, limit 0xa0000
smp_mp_probe: entry base 0xf0000, limit 0x100000
smp_mp_probe: found floating pointer structure at 0x000fce40
smp: intel mp version 1.4, virtual wire compatibility mode.
smp: invalid config table signature, aborting

Could be a problem with ACPI probing? Is there a newer version of BIOS/UEFI for this mobo?

comment:4 by bruno, 3 years ago

I tried the 64Bit (hrev 50908) Version without luck... ;-(

comment:5 by bruno, 3 years ago

hrev 50933 I did a BIOS update on my system... Multiprocessor is working now! Problem was the old BIOS from 2011! Ticket can be closed the! Thx...

...now I have UEFI too... good or not?!

comment:6 by diver, 3 years ago

Resolution: no change required
Status: newclosed

I'd say good :)

Note: See TracTickets for help on using tickets.