Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#13377 closed bug (duplicate)

Haiku fails to initialize display on Asus-F5R notebook PC

Reported by: Haiker Owned by: kallisti5
Priority: high Milestone: Unscheduled
Component: Drivers/Graphics/radeon Version: R1/Development
Keywords: Cc:
Blocked By: #3177 Blocking:
Has a Patch: no Platform: x86

Description

After boot screen system can't inicializate display driver. Graphics card is ATI Radeon Xpress 1100.

Attachments (1)

img0019a.jpg (67.1 KB) - added by Haiker 2 years ago.

Download all attachments as: .zip

Change History (16)

Changed 2 years ago by Haiker

Attachment: img0019a.jpg added

comment:1 Changed 2 years ago by Haiker

Has a Patch: set

comment:2 Changed 2 years ago by Haiker

Has a Patch: unset

comment:3 Changed 2 years ago by Morbid

Same problem with AMD A8-7600 Radeon R7. Vesa-Mode works.

comment:4 Changed 2 years ago by Morbid

device Display controller (VGA compatible controller, VGA controller) [3|0|0]

vendor 1002: Advanced Micro Devices, Inc. [AMD/ATI]

device 1313: Kaveri [Radeon R7 Graphics]

Last edited 2 years ago by Morbid (previous) (diff)

comment:5 Changed 2 years ago by vidrep

The issue with Radeon Xpress 1100 series graphics is a duplicate of ticket #3177. It's unlikely that a driver will ever be done for that or any other pre-Radeon HD chipset.

comment:6 Changed 2 years ago by vidrep

Owner: changed from euan to kallisti5
Status: newassigned

comment:7 Changed 2 years ago by vidrep

Summary: Haiku fails to inicializate display on Asus-F5R notebook PCHaiku fails to initialize display on Asus-F5R notebook PC

comment:8 Changed 2 years ago by kallisti5

I've never touched the pre-radeon_hd drivers and have no hardware to test pre-radeon hd.

If this ticket is about an R7 not working, i'll need some syslogs from the machine in question.

  1. Boot normally on system in question
  2. Wait 1 minute until machine is "up" (even is screen is scrambled)
  3. Press and hold ctl+alt+del
  4. Wait for system to reboot and release.
  5. Boot into Haiku via VESA mode. Collect /var/log/syslog and /var/log/syslog.old and post here.

If the machine never reboots on step 3... that means it didn't boot properly and a serial syslog is needed.

comment:9 Changed 2 years ago by waddlesplash

Component: Drivers/Graphics/radeonDrivers/Graphics/radeon_hd

comment:10 Changed 2 years ago by waddlesplash

Component: Drivers/Graphics/radeon_hdDrivers/Graphics/radeon

Oops, I thought the Xpress line was technically Radeon HD. Guess it's not.

comment:11 Changed 2 years ago by Morbid

No problems at start-up and on reboot.

comment:12 Changed 2 years ago by Morbid

Sorry, files are on my Win-PC but can't send syslogs (attachments). Get this: IndexError: pop from empty list caused by GET: /attachment/ticket/13377/. By pressing create new ticket (about this) i get: Request-URI Too Long The requested URL's length exceeds the capacity limit for this server. Apache/2.4.6 (Linux/SUSE) Server at vmdev.haiku-os.org Port 443

The same error occures at ticket #3177 for me.

Last edited 2 years ago by Morbid (previous) (diff)

comment:13 Changed 2 years ago by diver

Blocked By: 3177 added
Resolution: duplicate
Status: assignedclosed

comment:14 Changed 2 years ago by Morbid

Will try to send syslogs via Humdinger, if possible.

comment:15 in reply to:  8 Changed 2 years ago by Morbid

Replying to kallisti5:

I've never touched the pre-radeon_hd drivers and have no hardware to test pre-radeon hd.

If this ticket is about an R7 not working, i'll need some syslogs from the machine in question.

  1. Boot normally on system in question
  2. Wait 1 minute until machine is "up" (even is screen is scrambled)
  3. Press and hold ctl+alt+del
  4. Wait for system to reboot and release.
  5. Boot into Haiku via VESA mode. Collect /var/log/syslog and /var/log/syslog.old and post here.

If the machine never reboots on step 3... that means it didn't boot properly and a serial syslog is needed.

Syslogs are in #3177. Thx Humdinger.

Note: See TracTickets for help on using tickets.