Opened 3 years ago

Last modified 12 months ago

#13430 reopened bug

Workspaces are broken for me

Reported by: dsizzle Owned by: stippi
Priority: normal Milestone: Unscheduled
Component: User Interface Version: R1/Development
Keywords: workspaces, black screen Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86-64

Description

I haven't used Haiku in a while, but I just updated to hrev51090 and Workspaces don't work anymore. If I click on any workspace except the first one, my screen goes black and there is no way to recover. Even Ctrl-Alt-Shift-Esc doesn't bring back the screen. The only option is to hard reboot. It always worked fine in the past, and I don't know what rev it broke in, but now it doesn't work at all. :(

I tried several different screen resolutions and none work.

Attachments (1)

previous_syslog (175.5 KB ) - added by dsizzle 3 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 by humdinger, 3 years ago

Did you make sure you have "All workspaces" set in the Screen preferences when choosing your resolution? Otherwise, you may want to test older hrevs to see when things broke...

comment:2 by dsizzle, 3 years ago

I did another update today, and it seems to have fixed my workspace issue. I guess maybe something was out of sync? Feel free to close this ticket.

comment:3 by humdinger, 3 years ago

Resolution: not reproducible
Status: newclosed

OK. Without more specific info there's probably nothing much that can be investigated anyway. Next time, have a look into the syslogs at /system/var/log/ . Maybe there would've been a clue. Anyway, please reopen if it crops up again.

comment:4 by dsizzle, 3 years ago

Resolution: not reproducible
Status: closedreopened

This came back; not sure if it's because I updated, or messed with the font sizes and resolutions. The relevant part of the syslog sees to be this, but I will also attach the full log:

intel_extreme: CALLED status_t intel_get_edid_info(void *, long unsigned int, uint32 *)
intel_extreme: intel_set_display_mode(29285x26912)
intel_extreme: Video mode was adjusted by sanitize_display_mode
intel_extreme: Initial mode: Hd 65535 Hs 25599 He 28474 Ht 29811 Vd 114 Vs 32 Ve 0 Vt 29264
intel_extreme: Sanitized: Hd 8192 Hs 8160 He 8192 Ht 8192 Vd 200 Vs 201 Ve 264 Vt 4096
intel_extreme: IsConnected: LVDS C PortRegister: 0x5001180
intel_extreme: CALLED void Pipe::Enable(bool)
[36mAGP:[0m delete memory 0x82bae160
[36mAGP:[0m Aperture::CreateMemory(): did not find a free space large for this memory object
[36mAGP:[0m create memory 0x82bae160, base e0010000, size 57f000, flags 0
[36mAGP:[0m allocation is made of reserved memory
[36mAGP:[0m reserved memory already bound
intel_extreme: intel_set_display_mode: Failed to allocate framebuffer !
intel_extreme: CALLED status_t intel_get_edid_info(void *, long unsigned int, uint32 *)
intel_extreme: CALLED uint32 intel_accelerant_mode_count()
intel_extreme: CALLED status_t intel_get_mode_list(display_mode *)
Last edited 3 years ago by dsizzle (previous) (diff)

by dsizzle, 3 years ago

Attachment: previous_syslog added

comment:5 by dsizzle, 3 years ago

Has a Patch: set

comment:6 by dsizzle, 3 years ago

Sorry, I didn't think I clicked "Has a Patch" but now it's set and I can't see where to unset it. There is no patch, just the syslog.

Also, updating to the latest didn't fix the black screen issue for me this time. :(

comment:7 by pulkomandy, 3 years ago

This is a bug in Trac (the "has a patch" thing).

comment:8 by pulkomandy, 3 years ago

Has a Patch: unset

comment:9 by rhialto, 12 months ago

Exactly this just happened to me! Today I installed the install image https://cdn.haiku-os.org/haiku-release/r1beta1/haiku-r1beta1-x86_64-anyboot.zip to an usb stick on my laptop and then ran SoftwareUpdater to update whatever version is current today. Now I have exactly the problem as described at the top.

The system seems to be somewhat alive: if I briefly press the power button, then a minute or so later it shuts off.

Previously I had an older install from a few months ago, which corrupted its file system (hence I reinstalled); Workspaces in that older version worked fine.

My current version is R1/beta1 (Revision href52295+117) x86_64.

Last edited 12 months ago by rhialto (previous) (diff)

comment:10 by humdinger, 12 months ago

So only the first workspace works, done of the others? Did ou try what I suggested in my firsts comment on this ticket: Set a resolutions for "All workspaces" in the Screen prefs?

comment:11 by rhialto, 12 months ago

Ah thanks! I overlooked that. I went into the Screen preferences and changed resolution, then back (since not changing it isn't a change where you can press the Apply button for). Then the other workspaces worked properly.

(I was prepared with an ssh connection to check if the machine was actually still running despite the black screen, but I should have tested that before your suggestion. But I believe that it likely was.)

I'm not sure what Ctrl-Alt-Shift-Esc is supposed to do, but it also gives me a black screen. But with this I can at least blindly move to another workspace and see something again.

Note: See TracTickets for help on using tickets.