Opened 12 years ago

Closed 12 years ago

#1345 closed bug (fixed)

Data CD auto mounted as an Audio CD

Reported by: aldeck Owned by: axeld
Priority: normal Milestone: R1
Component: File Systems/cdda Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Data CD auto mounted as an Audio CD

Boot Haiku with a data cd or dvd inserted (tested iso, multitrack bfs) and it will get auto mounted as an audio cd on startup. Each track is showed as a .wav with the corresponding size.

Tested in vmware and real hardware with hrev21760.

Attachments (1)

audio-cd.png (75.5 KB) - added by scottmc 12 years ago.
screenshot of 22013 with Audio CD mounted

Download all attachments as: .zip

Change History (9)

Changed 12 years ago by scottmc

Attachment: audio-cd.png added

screenshot of 22013 with Audio CD mounted

comment:1 Changed 12 years ago by scottmc

Also related to this is that an audio CD shows a file cabinet icon instead of a cd icon as would be expected. This was checked on hrev22013 on vmware image with cd-rom enabled. Data CDs still show each data track as a wav file. I checked 3 or 4 different kinds of data CDs including some BFS ones.

comment:2 Changed 12 years ago by korli

Could you test again ? There was a possible fix committed in hrev22023.

comment:3 Changed 12 years ago by aldeck

Did a quick test with hrev22163, it works now, although isos don't get automounted it worked fine with a BFS or audio cd. I will do a more extensive test tonight, didn't try mixed audio+data cd for example. Also the icon issue as in the comment above is still there.

comment:4 Changed 12 years ago by axeld

Component: - GeneralFile Systems/cdda
Resolution: fixed
Status: newclosed

comment:5 in reply to:  3 Changed 12 years ago by scottmc

Resolution: fixed
Status: closedreopened

Replying to aldeck:

Did a quick test with hrev22163, it works now, although isos don't get automounted it worked fine with a BFS or audio cd. I will do a more extensive test tonight, didn't try mixed audio+data cd for example. Also the icon issue as in the comment above is still there.

I tested an audio CD that I know of that also has data and it only saw the audio portion, whereas BeOS sees both. I then removed that CD and put in a second CD and then tried dragging one of the wav files off the CD to play it and like before it thought it was still looking at the previous audio CD and get the track wrong. I then "unmounted" the CD and remounted it and did the drag and drop again and this time it worked. So it's better than it used to be but still not fixed 100%. Seems to just be lacking in an auto refresh function now. I haven't tried a combo BFS/ISO9660 CD that I have but will in a few more days. Seems there still is a good use for the Last Chance Wildcard Games CD I bought ;) Oh and yeah the icon is still a file cabinet for both data and audio CDs.

-reopened- (80% done I'd say)

comment:6 Changed 12 years ago by axeld

Sorry, but this bug is completely fixed. The problems you are seeing now are completely unrelated, and belong to a different bug.

comment:7 Changed 12 years ago by scottmc

You are correct. Original bug fixed. I'll open a new bug for the refresh issue, reclose this one as it is indeed fixed.

comment:8 Changed 12 years ago by axeld

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.