Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#1347 closed enhancement (duplicate)

DriveSetup needs more work done on its implementation

Reported by: jamesu Owned by:
Priority: normal Milestone: R1
Component: Preferences Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

The DriveSetup preferences app which currently resides in the repository (at src/preferences/drivesetup) is pretty much non-functional and incomplete. In order for end-user's to have any hope of installing Haiku on their systems, it needs to be further implemented, at least to match the functionality of the original DriveSetup.

For reference, as of revision 21777 DriveSetup doesn't even startup on its first attempt.

Attachments (2)

drivessetup_fix.diff (46.5 KB) - added by jamesu 12 years ago.
Patch to fix up DriveSetup so that it is usable for mounting volumes & ejecting devices
drivesetup_addtoimage.diff (544 bytes) - added by jamesu 12 years ago.
Add DriveSetup to the HaikuImage

Download all attachments as: .zip

Change History (7)

Changed 12 years ago by jamesu

Attachment: drivessetup_fix.diff added

Patch to fix up DriveSetup so that it is usable for mounting volumes & ejecting devices

Changed 12 years ago by jamesu

Attachment: drivesetup_addtoimage.diff added

Add DriveSetup to the HaikuImage

comment:1 Changed 12 years ago by axeld

Owner: axeld deleted

comment:2 Changed 11 years ago by bonefish

Resolution: duplicate
Status: newclosed

Duplicate of #970.

comment:3 Changed 11 years ago by stippi

Hi jamesu! I was completely unaware of your nice patch here. Damn... there is a lot of good work in there. I will try to extract some of your additions which I have not implemented yet. Sorry about that.

comment:4 Changed 11 years ago by jamesu

No problem stippi. I'm just glad you've been able to make use of this patch after over 7 months of it lying dormant.

comment:5 Changed 11 years ago by stippi

Urias just added an enhancement ticket for Trac, adding files should trigger a notification.

Note: See TracTickets for help on using tickets.