Opened 12 years ago

Closed 10 years ago

#1362 closed bug (fixed)

Executing Opera seems to wipe out IP settings

Reported by: tgx Owned by: axeld
Priority: normal Milestone: R1
Component: Network & Internet/Stack Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I have created two small scripts that I execute to set my IP settings as I do not have a DHCP system in place. The files are simple.

name setip ifconfig /dev/net/ipro1000/0 192.168.0.5 broadcast 192.168.0.255 netmask 255.255.255.0

name setroute route delete /dev/net/ipro1000/0 default 192.168.0.254 route add /dev/net/ipro1000/0 default gateway 192.168.0.1

After execution ifconfig and route shows that the settings are in place. I can then ping the local network as well as ping internet sites. When I execute Opera I then get page cannot be displayed. Leaving Opera open and going back to the shell I see that ifconfig shows the default IP information has been reinstated and my changes are gone. Re-running my script sets it back, then going into Opera I can now browse. I also note that periodically the IP information will get lost and browsing in Opera will cease requiring re-run of the scripts.

Change History (4)

comment:1 in reply to:  description Changed 12 years ago by tgx

I also note that periodically the IP information will get lost and browsing in

Opera will cease requiring re-run of the scripts.

Note, this part seems to be inaccurate. Please disregard.

comment:2 Changed 11 years ago by scottmc

Does this still happen?

comment:3 Changed 10 years ago by emitrax

Any updates on this one tgx? Can you still reproduce it?

comment:4 Changed 10 years ago by axeld

Resolution: fixed
Status: newclosed

I think I've fixed this one in the mean time; at least the problem could have been that after DHCP tried and failed after some time, the net_server set a default fallback IP configuration, disregarding if someone else already changed them while DHCP tried to get a configuration.

In any case, just use the network preferences app to configure a static IP address. No scripts needed.

Note: See TracTickets for help on using tickets.