Opened 12 years ago

Closed 12 years ago

#1363 closed bug (fixed)

PANIC: vm_page_fault: unhandled page fault in kernel space (rev21847)

Reported by: kaliber Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I'm using vmware image.

  1. wget ..../libxml2-2.6.27.tar.bz2
  2. tar xfvj libxml2-2.6.27.tar.bz2
vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0xa02e0000, ip 0x8009b758, write 0, user 0, thread 0x8d
PANIC: vm_page_fault: unhandled page fault in kernel space at 0xa02e0000, ip 0x8009b758

Welcome to Kernel Debugging Land...
Running on CPU 0
kdebug> bt
stack trace for thread 0x8d "tar"
    kernel stack: 0x906a2000 to 0x906a6000
      user stack: 0x7efe7000 to 0x7ffe7000
frame            caller     <image>:function + offset
906a5500 (+  52) 80086fbc   <kernel>:invoke_command + 0x0074
906a5534 (+  48) 800870da   <kernel>:kernel_debugger_loop + 0x00de
906a5564 (+  32) 80087b66   <kernel>:kernel_debugger + 0x00b2
906a5584 (+ 192) 80087aa9   <kernel>:panic + 0x0029
906a5644 (+  64) 8005846b   <kernel>:vm_page_fault + 0x00ab
906a5684 (+ 176) 8009025b   <kernel>:i386_handle_trap + 0x0217
iframe at 0x906a573c (end = 0x906a5790)
 eax 0x0            ebx 0xa02e0000      ecx 0xa02dfe24   edx 0x1
 esi 0x10           edi 0xa02dfe18      ebp 0x906a5794   esp 0x906a576c
 eip 0x8009b758  eflags 0x10202
 vector: 0xe, error code: 0x0
906a5734 (+  96) 8009b758   <kernel>:memmove + 0x006c
906a5794 (+ 128) 80236c36   <bfs>:_SplitNode__9BPlusTreeP14bplustree_nodexT1xPUsPUcT5Px + 0x06a2
906a5814 (+ 496) 8023732d   <bfs>:Insert__9BPlusTreeR11TransactionPCUcUsx + 0x0641
906a5a04 (+  80) 8023b9e5   <bfs>:Update__5IndexR11TransactionPCclPCUcUsT4UsP5Inode + 0x0235
906a5a54 (+  80) 8023bb0b   <bfs>:UpdateName__5IndexR11TransactionPCcT2P5Inode + 0x007f
906a5aa4 (+  64) 8023ba4a   <bfs>:InsertName__5IndexR11TransactionPCcP5Inode + 0x002e
906a5ae4 (+ 144) 802423fd   <bfs>:Create__5InodeR11TransactionP5InodePCcliUlPbPxPP5Inode + 0x07d1
906a5b74 (+  96) 8024a205   <bfs>:bfs_create__FPvT0PCciiPPvPx + 0x0135
906a5bd4 (+  80) 800477e1   <kernel>:create_vnode__FP5vnodePCciib + 0x0055
906a5c24 (+ 320) 80047b9a   <kernel>:file_create__FiPciib + 0x005a
906a5d64 (+  80) 8004cbf4   <kernel>:_user_open + 0x00bc
906a5db4 (+ 336) 80034d38   <kernel>:syscall_dispatcher + 0x07dc
906a5f04 (+ 160) 800902f4   <kernel>:i386_handle_trap + 0x02b0
iframe at 0x906a5fac (end = 0x906a6000)
 eax 0x44           ebx 0x2c3770        ecx 0x1801c368   edx 0x8301
 esi 0x8301         edi 0x1b4           ebp 0x7ffe6d8c   esp 0x906a5fdc
 eip 0xffff0102  eflags 0x206
 vector: 0x63, error code: 0x0
906a5fa4 (+   0) ffff0102
7ffe6d8c (+ 336) 0020e92f   </bin/tar@0x00200000>:unknown + 0xe92f
7ffe6edc (+ 112) 00212461   </bin/tar@0x00200000>:unknown + 0x12461
7ffe6f4c (+  48) 0021cd84   </bin/tar@0x00200000>:unknown + 0x1cd84
7ffe6f7c (+  48) 00207573   </bin/tar@0x00200000>:unknown + 0x7573
7ffe6fac (+  48) 001007ae   1379:runtime_loader_seg0ro@0x00100000 + 0x7ae
7ffe6fdc (+   0) 7ffe6fec   1378:/bin/tar_main_stack@0x7efe7000 + 0xffffec
kdebug>

Change History (5)

comment:1 by aldeck, 12 years ago

It worked here two times on libxml2.tar.bz2 . But got the same backtrace on another tgz archive.

in reply to:  1 comment:2 by jackburton, 12 years ago

Replying to aldeck:

It worked here two times on libxml2.tar.bz2 . But got the same backtrace on another tgz archive.

I got the same backtrace on unzipping a zip archive. Looks like this could be a dup of bug #1003, and that one has not been fixed completely ? Although it's much harder to reproduce now.

comment:3 by axeld, 12 years ago

#1003 has been fixed, but the SplitNode() method obviously has another bug :-) In the old bug, it crashed at another memmove(), and for obviously different reasons, so I think this new bug makes sense.

comment:4 by kaliber, 12 years ago

Is any progress on this bug? I'm asking because it's quite important, filesystem should be stable like a rock :)

comment:5 by bonefish, 12 years ago

Resolution: fixed
Status: newclosed

Fixed in hrev22195.

Note: See TracTickets for help on using tickets.