Opened 2 years ago

Closed 2 years ago

#13626 closed bug (fixed)

GMail standard webinterface doesn't load anymore

Reported by: humdinger Owned by: pulkomandy
Priority: normal Milestone: Unscheduled
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev51307.

After the latest WebKit update in hrev51283, the standard webinterface doesn't load anymore. Going to the basic interface doesn't help much, because the mails are linked as e.g. "?&th=15d78550c5746c4d&v=c" and open a about:blank page.

Change History (5)

comment:1 Changed 2 years ago by humdinger

I just realized that my web troubles didn't come with the new webkit1.6, as I already used that when it all worked with hrev51276! I overlooked that the recent webkit update was for 64bit...

Doesn't work here anyway...

comment:2 Changed 2 years ago by humdinger

As it turns out from a binary-search of past revisions, the regressions started with hrev51291 when the very outdated jam package was updated for gcc2hybrid Haiku. The speculation is that -O2 optimization might have to do with it, see btrev43089.

comment:3 Changed 2 years ago by anevilyak

I have a difficult time seeing how that optimization change would be the cause. If it's triggering a bug in the OS itself, then it should long since have been visible since the nightlies to my knowledge rebuild the cross tools including jam every time (ergo should have included said commit since 3 years ago). This should theoretically only affect packages built on Haiku itself afterwards, and none were changed.

comment:4 Changed 2 years ago by pulkomandy

I think I have found the bug, yet another race condition in HaikuWebKit network code. I don't know why, but it seems starting from this commit, Haiku is more optimized and the race will happen more often.

Other noticed ill effects:

  • After logging in, github will fail to load its CSS. Refreshing the page fixes it.

comment:5 Changed 2 years ago by humdinger

Resolution: fixed
Status: newclosed

All fixed with hrev51316 webkit 1.6.1. Thanks!

Note: See TracTickets for help on using tickets.