Opened 2 years ago

Closed 2 years ago

#13627 closed bug (fixed)

Redirecting error at http://echelog.com/logs/browse/haiku

Reported by: humdinger Owned by: pulkomandy
Priority: normal Milestone: Unscheduled
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev51307.

After the webkit update in hrev51283, going to http://echelog.com/logs/browse/haiku redirects to e.g. http://echelog.com/logs/browse/haiku/1500933600, but the URL bar only shows /logs/browse/haiku/1500933600. A click on the "bottom" link fails, it only links to "#bottom'.

Change History (4)

comment:1 by humdinger, 2 years ago

I just realized that my web troubles didn't come with the new webkit1.6, as I already used that when it all worked with hrev51276! I overlooked that the recent webkit update was for 64bit... Sorry about that, but it makes it all even more mysterious...

comment:2 by accessays, 2 years ago

I've just tried that link on x86_64, hrev51308 and everything seems to work correctly. Are you running hybrid or 64bit build?

comment:3 by pulkomandy, 2 years ago

Likely related to #13626, for which the root cause is already identified. Not always reproductible because it is a race condition and depends on number of CPU cores, CPU speed, and network connection speed.

I will make a new WebKit release "soon" (maybe this week end).

comment:4 by humdinger, 2 years ago

Resolution: fixed
Status: newclosed

All fixed with hrev51316 webkit 1.6.1. Thanks!

Note: See TracTickets for help on using tickets.