Opened 3 years ago

Closed 3 years ago

Last modified 6 months ago

#13657 closed bug (fixed)

[WebPositive] GitHub no longer supports old versions of Safari

Reported by: Giova84 Owned by: pulkomandy
Priority: normal Milestone: R1/beta1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: x86

Description (last modified by diver)

hrev51346 gcc2h

Well, I noticed since few days, that both WebPositive and QupZilla are no longer recognised as supported browsers on GitHub. There is an alert banner which say:

Please note that GitHub no longer supports old versions of Safari. We recommend upgrading to the latest Safari, Google Chrome, or Firefox.

For what is worth, despite the alert which appearing now on GitHub (see the attached screenshot), I never found (also in past) good success to use GitHub's website on Haiku's browsers: on QupZilla the buttons and menus doesn't works at all; with WebPositive, in past, I experienced full screen debugger (similar to KDL, see ticket:12870) and currently I am totally unable to login on GitHub (it told me "wrong username or password" but I insert the right user and password).

Attachments (1)

WebPositive_Github.png (127.7 KB ) - added by Giova84 3 years ago.

Download all attachments as: .zip

Change History (18)

by Giova84, 3 years ago

Attachment: WebPositive_Github.png added

comment:1 by Giova84, 3 years ago

patch: 01

comment:2 by diver, 3 years ago

Description: modified (diff)
Milestone: UnscheduledR1/beta1
Summary: Haiku's browsers on GitHub: "GitHub no longer supports old versions of Safari"[WebPositive] GitHub no longer supports old versions of Safari

As for QupZilla, it was already fixed in QtWebKit (recipe and patches committed but packages haven't been uploaded yet).

The work for HaikuWebKit can be tracked in https://github.com/haiku/webkit/commits/rebased

comment:3 by Giova84, 3 years ago

Thanks for these links and also for the fix of my typos :-)

comment:4 by pulkomandy, 3 years ago

patch: 10

comment:5 by pulkomandy, 3 years ago

patch: 0

I have no problem signing in on github with WebPositive here (version 1.6.1 - 1.6.0 is known to still have some HTTP bugs). As for the warning, the only way out is to update to a newer version, which I'm currently working on but it may take a few more days or weeks before I get there.

in reply to:  5 comment:6 by korli, 3 years ago

patch: 0

Replying to pulkomandy:

I have no problem signing in on github with WebPositive here (version 1.6.1 - 1.6.0 is known to still have some HTTP bugs).

Did you try to fork a repository?

comment:7 by pulkomandy, 3 years ago

No, I just use the "hub" command line tool for that.

comment:8 by diver, 3 years ago

Turns out I was wrong about QupZilla/QtWebKit as it shows the same warning. However, in QupZilla you can change user agent for specific website. Setting it top Opera (from a dropdown list) makes it go away. It seems that we need to update user agent in qtwebkit to pretend we're on a newer Safari.

in reply to:  7 comment:9 by korli, 3 years ago

Replying to pulkomandy:

No, I just use the "hub" command line tool for that.

I mean, the Github button "fork" doesn't work in WebPositive (1.6.0). It's easy to reproduce.

comment:10 by pulkomandy, 3 years ago

Try 1.6.1 please. The main reason I made 1.6.1 is a big problem which would break everything in the HTTP code (in my case leading to failing to load the CSS on github, for example) and there is no point in debugging older versions again.

in reply to:  8 comment:11 by pulkomandy, 3 years ago

Replying to diver:

Turns out I was wrong about QupZilla/QtWebKit as it shows the same warning. However, in QupZilla you can change user agent for specific website. Setting it top Opera (from a dropdown list) makes it go away. It seems that we need to update user agent in qtwebkit to pretend we're on a newer Safari.

It depends which part of the user agent they detect. If it is the WebKit version, then there is no choice but updating (I don't want to lie on that in the user agent). If they use some other part of the string, then yes, we could look at current Safari UA and see what we need to change to match even closer to it.

The current UA for Safari:

Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12) AppleWebKit/602.1.18 (KHTML, like Gecko) Version/9.2 Safari/602.1.18

And for Web+:

Mozilla/5.0 (Macintosh; Intel Haiku R1 x86) AppleWebKit/601.1.30 (KHTML, like Gecko) WebPositive/1.2 Version/8.0 Safari/601.1.30

So it's possible we can get away by just bumping the "Version" in there?

comment:12 by diver, 3 years ago

I tried 1.6.1 on x86_64 and Fork button at Github doesn't work.

comment:13 by pulkomandy, 3 years ago

Resolution: fixed
Status: newclosed

Confirmed that changing the Version/8.0 to Version/9.2 in the user agent is enough to make the warning go away. Will be part of the next WebKit release. Please open separate bugs for the other problems :)

comment:14 by diver, 3 years ago

Since things like that pop up from time to time wouldn't it be handy to have user agent editable?

comment:15 by pulkomandy, 3 years ago

Yes, there is already a ticket for that. Patches welcome, but I fear that people would just change their user agent and would never report bugs about the default user agent being a problem. Also, why should people mess with the user agent in the first place? Better fix the web to stop relying on it.

comment:16 by grexe, 6 months ago

so this warning still pops up with WebPositive 1.1-alpha included with latest Haiku hrev53894, should I bother Github or is there a patch for WebPositive/HaikuWebkit in the pipeline? Or will the 1.6.1 branch that @pulkomandy mentioned above be merged into Haiku mainline soon?

Last edited 6 months ago by grexe (previous) (diff)

comment:17 by pulkomandy, 6 months ago

Both.

The 1.6.1 version has been merged (this ticket is 3 years old). But Github bump their version requirement from time to time and the warning keeps coming back. As far as I can see they are using the user agent to decide if a browser is compatible, which is a bad thing to do.

There is a much more up to date version of WebKit in the WebKit branch, however it has other problems, in particular, review.haiku-os.org only renders a webpage, which is why there was no release of it yet (other pages work just fine and I have no idea why this particular one wouldn't).

So, it would be great if Github would stop thinking we're Safari, and we should also update the browser :)

Note: See TracTickets for help on using tickets.