Opened 3 years ago

Last modified 6 months ago

#13657 closed bug

[WebPositive] GitHub no longer supports old versions of Safari — at Version 2

Reported by: Giova84 Owned by: pulkomandy
Priority: normal Milestone: R1/beta1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: x86

Description (last modified by diver)

hrev51346 gcc2h

Well, I noticed since few days, that both WebPositive and QupZilla are no longer recognised as supported browsers on GitHub. There is an alert banner which say:

Please note that GitHub no longer supports old versions of Safari. We recommend upgrading to the latest Safari, Google Chrome, or Firefox.

For what is worth, despite the alert which appearing now on GitHub (see the attached screenshot), I never found (also in past) good success to use GitHub's website on Haiku's browsers: on QupZilla the buttons and menus doesn't works at all; with WebPositive, in past, I experienced full screen debugger (similar to KDL, see ticket:12870) and currently I am totally unable to login on GitHub (it told me "wrong username or password" but I insert the right user and password).

Change History (3)

by Giova84, 3 years ago

Attachment: WebPositive_Github.png added

comment:1 by Giova84, 3 years ago

patch: 01

comment:2 by diver, 3 years ago

Description: modified (diff)
Milestone: UnscheduledR1/beta1
Summary: Haiku's browsers on GitHub: "GitHub no longer supports old versions of Safari"[WebPositive] GitHub no longer supports old versions of Safari

As for QupZilla, it was already fixed in QtWebKit (recipe and patches committed but packages haven't been uploaded yet).

The work for HaikuWebKit can be tracked in https://github.com/haiku/webkit/commits/rebased

Note: See TracTickets for help on using tickets.