Opened 21 months ago

Last modified 20 months ago

#13664 reopened bug

[WebPositive] horizontal scrollbar knob not being drawn

Reported by: diver Owned by: pulkomandy
Priority: normal Milestone: Unscheduled
Component: Kits/Interface Kit Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Change History (7)

comment:1 Changed 20 months ago by pulkomandy

You mean horizontal, right?

comment:2 Changed 20 months ago by diver

Summary: [WebPositive] verticall scrollbar knob not being drawn[WebPositive] horizontal scrollbar knob not being drawn

Oh, right!

comment:3 Changed 20 months ago by pulkomandy

Component: Applications/WebPositiveKits/Interface Kit
Owner: changed from pulkomandy to nobody

I checked the code in WebKit for this, and it is doing everything as needed. I replaced the code to draw the knob by a simple FillRect and that worked as expected.

So, I think this is a bug in BControlLook or in BGradient. Possibly one of these doesn't work well when transforms or clipping is used?

comment:4 Changed 20 months ago by pulkomandy

Owner: changed from nobody to pulkomandy
Status: newassigned

comment:5 Changed 20 months ago by pulkomandy

I confirm a problem in BControlLook when transforms are used.

BControlLook uses ConstrainClippingRegion a lot, in particular to draw buttons with rounded corners. However, ConstrainClippingRegion does not play well with transforms, and other methods should be used instead.

I'm going to rewirte the code using ClipToShape, which should make it both simpler and faster, and also fix the problem.

comment:6 Changed 20 months ago by pulkomandy

Resolution: fixed
Status: assignedclosed

Fixed in hrev51369. Solution for this particular problem was simpler than I expected.

comment:7 Changed 20 months ago by diver

Resolution: fixed
Status: closedreopened

Just updated to hrev51369 and the issue is still there.

Note: See TracTickets for help on using tickets.