Opened 21 months ago

Closed 7 months ago

#13760 closed bug (fixed)

TextSearch silently quits on big search

Reported by: humdinger Owned by: phoudoin
Priority: normal Milestone: Unscheduled
Component: Applications/TextSearch Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev51528.

With hrev51525 TextSearch became massively faster. Yay!

Unfortunately it silently quits on big searches, like when looking for "Window.h" in Haiku's "src" folder.

No error message in syslog or when started from Terminal.

Attachments (3)

TextSearch_terminal_output.txt (60.8 KB) - added by humdinger 21 months ago.
Output searching "Window.h" in haiku/src/
TextSearch-3851-debug-07-11-2017-14-32-42.report (45.9 KB) - added by humdinger 21 months ago.
reproducible for huge source code repo on /Source partition
TextSearch-4065-debug-07-11-2017-14-34-15.report (53.6 KB) - added by humdinger 21 months ago.
NOT reproducible for huge source code repo on /Source partition

Download all attachments as: .zip

Change History (15)

comment:1 Changed 21 months ago by phoudoin

You have zero output on Terminal before it quits when launched from Terminal?! Haiku x86 or x86_64? Did you see some xargs activity in ProcessController before it does?

I tried here but failed to reproduce. Which make me wanting to add a "N matching files found:" text on the window, above the result list, BTW...

Last edited 21 months ago by phoudoin (previous) (diff)

comment:2 Changed 21 months ago by humdinger

When started via add-on: I see the search results appearing in the TextSearch window, and after 1/10 second - pop! - the Textsearch window disappears. It's too quick to see more than the PC replicant quickly lighting up.

When started from Terminal: Same as above, maybe goes on 2/10 seconds longer. I also see the results appearing in Terminal.

When started via QuickLaunch or Shortcuts preferences: The TextSearch window immediately disappears as soon as I hit the "Search" button. No reaction from the PC replicant. Probably related to the annoying bug #12534

This is all on gcc2h.

comment:3 Changed 21 months ago by phoudoin

Platform: Allx86

comment:4 in reply to:  2 ; Changed 21 months ago by phoudoin

Replying to humdinger:

When started from Terminal: Same as above, maybe goes on 2/10 seconds longer. I also see the results appearing in Terminal.

Could you post what appears in Terminal in such case? It could help me to figure out where it stops.

Does the same happend when searching on smaller sets of files or only on large ones?

This is all on gcc2h

Okay, that narrow it a bit down at least.

Changed 21 months ago by humdinger

Output searching "Window.h" in haiku/src/

comment:5 Changed 21 months ago by humdinger

Has a Patch: set

comment:6 Changed 21 months ago by phoudoin

Oh, now that's a silent quit, indeed, as everything seems fine right before.

comment:7 in reply to:  4 Changed 21 months ago by humdinger

Replying to Philippe Houdoin:

Could you post what appears in Terminal in such case? It could help me to figure out where it stops.

I attached the Terminal output.

Does the same happend when searching on smaller sets of files or only on large ones?

Only seen it on large sets, seemingly.
While searching through only the subfolders of haiku/src/, the TextSearch window didn't disappear at all. But I got this when limiting the search to haiku/src/data/ :

xargs: unmatched single quote; by default quotes are special to xargs unless you use the -0 option

I also got the attached two crashes when searching through my huge source code partition "/Source". checkfs says all's clean. One of the crashes is reproducible, showing this in syslog:

KERN: vm_soft_fault: va 0x32482000 not covered by area in address space
KERN: vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0x32482f6c, ip 0x10ba1ca, write 0, user 1, thread 0x1217
KERN: vm_page_fault: thread "Grep runner" (4631) in team "TextSearch" (4620) tried to read address 0x32482f6c, ip 0x10ba1ca ("TextSearch_seg0ro" +0x121ca)
KERN: debug_server: Thread 4631 entered the debugger: Segment violation
KERN: stack trace, current PC 0x10ba1ca  _RunnerThread__7Grepper + 0x8c6:
KERN:   (0x7a146818)  0x726f7463  
KERN: vm_soft_fault: va 0x75727000 not covered by area in address space
KERN: vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0x75727473, ip 0x80140ed3, write 0, user 0, thread 0x1224
KERN: vm_soft_fault: va 0x75727000 not covered by area in address space
KERN: vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0x75727473, ip 0x80140ed3, write 0, user 0, thread 0x1224

Changed 21 months ago by humdinger

reproducible for huge source code repo on /Source partition

Changed 21 months ago by humdinger

NOT reproducible for huge source code repo on /Source partition

comment:8 Changed 21 months ago by phoudoin

Platform: x86All

Reproduced on my x86_64. Investigation pending...

comment:9 Changed 21 months ago by phoudoin

The xargs error on quote on "Dovrak (programmer's).keymap" should be fixed now. Still investigating silent quit.

comment:10 Changed 18 months ago by pulkomandy

Has a Patch: unset

comment:11 Changed 7 months ago by humdinger

Can't reproduce any more. Shall close this ticket, phoudoin?

The only issue with a search that has a huge result list - like looking for "Window" in the "src" folder - is that the TextSearch window becomes unresponsive. That would be another ticket, though.

comment:12 Changed 7 months ago by waddlesplash

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.