Opened 21 months ago

Closed 4 months ago

#13875 closed bug (not reproducible)

Haiku anyboot image corruption when writing to CD?

Reported by: vidrep Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev51677 x86_64

Download Haiku nightly anyboot image

Write image to CD with cdrecord using the following command line:

cdrecord dev=10,1,0 speed=16 -dao -v /boot/home/haiku-nightly-anyboot.iso

Approximately 50% of the time the resulting disc is corrupted in some manner that causes a KDL when attempting to mount or boot the image.

Attached are syslogs of both a good and bad installation CD.

Attachments (3)

anyboot_disc_good (5.4 KB ) - added by vidrep 21 months ago.
anyboot_disc_bad (5.0 KB ) - added by vidrep 21 months ago.
IMG_0025.JPG (645.0 KB ) - added by vidrep 21 months ago.

Download all attachments as: .zip

Change History (10)

by vidrep, 21 months ago

Attachment: anyboot_disc_good added

comment:1 by vidrep, 21 months ago

Has a Patch: set

by vidrep, 21 months ago

Attachment: anyboot_disc_bad added

comment:2 by mmlr, 21 months ago

Can you try to run a checksum on the produced discs (using sha1sum on the raw device) and see if they are actually different? Does the bad disc always fail and the good always work?

comment:3 by vidrep, 21 months ago

The dud disc will KDL on the 4th icon every time. The good disc always boots OK. I have attached a photo of the KDL.

by vidrep, 21 months ago

Attachment: IMG_0025.JPG added

comment:4 by bruno, 21 months ago

same too hrev51671 x86_64 and hrev51671 x86_32 using: cdrecord dev=8,1,0 driveropts=burnfree -v -eject -dao -data haiku.iso

Last edited 21 months ago by bruno (previous) (diff)

comment:5 by bruno, 21 months ago

I just downloaded hrev 52686 x86_32 gcc2 and burned it with InfraRecorder and this one does not boot until the 4.th icon too... it just switched to boot from hdd then booted into Haiku...

Last edited 21 months ago by bruno (previous) (diff)

comment:6 by pulkomandy, 21 months ago

Has a Patch: unset

comment:7 by vidrep, 4 months ago

Resolution: not reproducible
Status: newclosed

I've burned a lot of anyboot images since my last comment 18 months ago, and I have not seen the problem again. Closing.

Note: See TracTickets for help on using tickets.