Opened 18 months ago

Last modified 7 days ago

#13876 new bug

A crash on a WebSDR site.

Reported by: WildKeccak Owned by: pulkomandy
Priority: normal Milestone: Unscheduled
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Appears to be related to the gorgeous waterfall displays.

http://69.27.184.62:8901/

Attaching a debugger may help. There was something it couldn't draw, but then the debugger closed suddenly, and it wasn't in the report, not that I could see.

Attachments (1)

WebPositive-6887-debug-15-12-2017-17-39-39.report (142.1 KB) - added by WildKeccak 18 months ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 18 months ago by WildKeccak

Has a Patch: set

comment:2 Changed 17 months ago by WildKeccak

WebPositive's stop reason was "could not create BWindow's receive port, used for interacting with the app server!"

comment:3 Changed 17 months ago by WildKeccak

I notice that there are a few thousand semaphores in the debug report.

comment:4 Changed 17 months ago by pulkomandy

Has a Patch: unset

comment:5 Changed 7 days ago by waddlesplash

Component: ApplicationsServers/app_server
Owner: changed from nobody to axeld

No more WebPositive crash ... but this site now causes an app_server crash.

comment:6 Changed 7 days ago by waddlesplash

Component: Servers/app_serverApplications/WebPositive
Owner: changed from axeld to pulkomandy

Never mind, the crash was just an OOM assert failure in rpmalloc on my test build.

Note: See TracTickets for help on using tickets.