Opened 22 months ago

Closed 22 months ago

Last modified 22 months ago

#13915 closed bug (no change required)

ACPI causes troubles

Reported by: Giova84 Owned by: tqh
Priority: low Milestone: Unscheduled
Component: Drivers/ACPI Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

After a search about the fact that I see the clock (and also the whole system) going slow, I discovered this ticket: ticket:6152; not only the clock goes slow; the whole system was slow...

Well, as I disabled ACPI in the kernel settings file, everything goes fine...

Vaio VGN FS215E Celeron M 1,50 GHZ

hrev51714 gcc2h

Attachments (2)

DSC_0055.JPG (1.9 MB ) - added by Giova84 22 months ago.
syslog_ACPI_enabled (222.5 KB ) - added by Giova84 22 months ago.

Change History (29)

comment:1 by Giova84, 22 months ago

With ACPI disabled, obviously I cannot use PowerStatus app to check the battery, so I enabled APM in the kernel setting file: at the next reboot, when I launched PowerStatus, I got a KDL. (I attach a screenshot). Then I reboot again Haiku, and I start Qupzilla, and the system freezed. Furthermore, at the next boot, despite the fact that my net is working, stopped to work: as I also attempt to ping any host, I always get "unknow host". So I re-enaled APM: at least the net and the clock, are working ok...

I know: I have to attach a syslog, but ATM I am on another computer; i will attach the syslog soon.

by Giova84, 22 months ago

Attachment: DSC_0055.JPG added

comment:2 by Giova84, 22 months ago

Has a Patch: set

comment:3 by Giova84, 22 months ago

Has a Patch: unset

comment:4 by Giova84, 22 months ago

Maybe is unrelated, but without ACPI i cannot check the status of the battery. But here https://discuss.haiku-os.org/t/huge-battery-drain-of-notebooks-battery/6378 I reported another trouble which is about an huge battery drain.

comment:5 by Giova84, 22 months ago

I re-enaled APM: at least the net and the clock, are working ok

Sorry, I mixed up things.. 1: APM enabled and ACPI disabled = no connectivity, the clock goes ok, there is no battery drain 2: ACPI enabled APM disabled = I have connectivity, the clock goes slow and there is an huge battery drain

I also found that with 1, after a while the system completely freeze..., and that to have connectivity, oddly, I have to blacklist Intel_extreme driver. Oh, i forget: with 1, Haiku will also hangs, during boot, to the disk icon. In these days I will attach a syslog, I promise :-)

Last edited 22 months ago by Giova84 (previous) (diff)

comment:6 by Giova84, 22 months ago

Ok I attach the syslog with ACPI enabled.

To summarize what happens with ACPI enabled: When the laptop is on battery (power plug detached) the clock is slow and also the system is slow (on boot and in opening folders, files and apps) There is an high battery drain.

What I also discovered: despite the fact that the wlan switch is off, I can still see available wifi networks. When I shutdown Haiku, the green led on the panel of the laptop (power on) remains active; to really turn off the laptop I have to remove the battery, or if the battery is not present, I have to unplug the power plug. When I reboot Haiku, the laptop hangs on the OEM's bios logo. doing CTR+ALT+CANC doesn't help to complete the reboot process: I have to press the powef off switch.

What I tried to do: blacklists many drivers: wlan, ethernet and intel_extreme

I hope that this syslog will help to investigate the cause of all these problems, which are very frustrating..

by Giova84, 22 months ago

Attachment: syslog_ACPI_enabled added

comment:7 by Giova84, 22 months ago

Has a Patch: set

comment:8 by Giova84, 22 months ago

Has a Patch: unset

comment:9 by tqh, 22 months ago

First thing to check if there are any firmware/bios upgrades for your computer. Old computers had really broken firmwares before. Most likely it's a driver that behaves weird when ACPI is enabled. Can you see is some process is using a lot of CPU when you havn't started any apps? You can start ActivityMonitor and right-click to see what thread is using most CPU. Also it is really hard to do anything without syslog. You may also try to blacklist the firewire driver.

comment:10 by Giova84, 22 months ago

Hi, first of all, if you look above the comment 7, you will see the syslog :-) The BIOS of such laptop is up-to-date: before I had Windows XP and I didn't encouter any issue which I described here. By loking to activity monitor (and ProcessController) I don't notice any process/driver that behaves weird, but I will investigate further.

comment:11 by Giova84, 22 months ago

PS: the firewire driver was already disabled, but didn't change anything.

comment:12 by tqh, 22 months ago

Windows and Linux has a lot of special code to handle broken firmwares. Always check if there is an update. We don't have the manpower to handle the old broken ones. In the syslog I see firewire is running, so don't think you disabled it completly.

comment:13 by tqh, 22 months ago

Priority: normallow

The reason for cpu drain is that you don't have any valid cpu-idle module: "no valid cpuidle module found". It also fails to setup a IRQ, which is a hint to invalid info in ACPI tables, most likely due to bad firmware. Are you trying to use APM and ACPI at the same time? That would be bad as they both try to manage the same things.

Unfortunatly I think that your cpu is so old that we don't fully support it (we don't even have correct cpu halting for it), and the firmware in your machine is broken for ACPI. Not spending time on this as the machine is more likely to be the problem, and it is close to or has passed it end of life already.

comment:14 by Giova84, 22 months ago

I have the latest availble update (BIOS). Haiku Alpha 4 doesn't show these troubles. In the blacklist package setting file I have

        add-ons/kernel/bus_managers/firewire
        add-ons/media/firewire_dv.media_addon

If I run listimage | grep driver I get

[baron@haiku-sony] # listimage | grep driver
   59 0x8159e000 0x815a5000     0          0 /boot/system/add-ons/kernel/drivers/disk/virtual/ram_disk
   71 0x81105000 0x81106000     0          0 /boot/system/add-ons/kernel/drivers/dev/dprintf
   72 0x815c9000 0x815ca000     0          0 /boot/system/add-ons/kernel/drivers/dev/zero
   73 0x81911000 0x81912000     0          0 /boot/system/add-ons/kernel/drivers/dev/null
   74 0x81830000 0x81832000     0          0 /boot/system/add-ons/kernel/drivers/dev/console
   75 0x815a6000 0x815af000     0          0 /boot/system/add-ons/kernel/drivers/dev/tty
  743 0xdde14000 0xdde16000     0          0 /boot/system/add-ons/kernel/drivers/power/acpi_button
  755 0xdde17000 0xdde19000     0          0 /boot/system/add-ons/kernel/drivers/power/acpi_battery
 1035 0x81813000 0x81817000     0          0 /boot/system/add-ons/kernel/drivers/dev/graphics/vesa
 1179 0x81123000 0x8113e000     0          0 /boot/system/add-ons/kernel/drivers/dev/net/ipro100
 2103 0x8197e000 0x81980000     0          0 /boot/system/add-ons/kernel/drivers/dev/input/wacom
 2922 0x819a9000 0x819b5000     0          0 /boot/system/add-ons/kernel/drivers/dev/audio/hmulti/hda
 2995 0x81c80000 0x81c82000     0          0 /boot/system/add-ons/kernel/drivers/dev/bus/usb_raw
 3772 0xcce9c000 0xccea9000     0          0 /boot/system/add-ons/kernel/drivers/dev/input/usb_hid
 3557 0x00c9e000 0x00caa000     0          0 /boot/system/add-ons/x86/Qt5/sqldrivers/libqsqlite.so
TEAM 1792 (/bin/grep --color=auto driver):
[baron@haiku-sony] #

And so in the Media Preflet the Firewire is not present.

However: I also run TOP (the commandline utility) and I didn't notice nothing of strange; then I run Slayer (the task manager utility from HaikuDepot), I noticed an interesting thing: as I moved the pointer of the mouse, there was an increased activity of the CPU.

As I've said, the described issue of slowliness appears only when the Laptop is on battery and ACPI is enabled. If the battery were poor, I expected to see these issues also with ACPI disabled and also on Haiku Alpha 4.

Well: as I moved the pointer of mouse, the CPU activity in ActivityMonitor incresed until 43%! But the system is slow also if I unplug the mouse (USB). Then I opened Slayer, wich shows the CPU usage graph of every background process: when I move the mouse, the most revelant processes whcih peg the cpu are app_server and input_server, for both of them "event loop".

Obviously the first thing that I done, has been to change the mouse, but with no luck; furthermore, this mouse on any other OS doesn't cause any issue. The input devices are related to ACPI? I repeat that with ACPI enabled the system is slow, the batery drain is huge and the Laptop don't shutdown completely. APM and ACPI aren't enabled at the same time, and I repeat that by using Haiku Alpha 4 I don't have these issues.

comment:15 by Giova84, 22 months ago

the firmware in your machine is broken for ACPI

If the firmware were broken for ACPI, I would face the same on other operating system?

comment:16 by Giova84, 22 months ago

Sorry Fredrik, but I think that is a little bit rude come to the conclusion that the firmware is broken without propose an analysis that can prove it, I say this with a friendly smile, dont you worry :-)

If I had the same problem on Haiku Alpha 4, otherwise I wouldn't open this ticket, and so is certain a regression somewhere.

Last edited 22 months ago by Giova84 (previous) (diff)

comment:17 by tqh, 22 months ago

No, they built a lot of code just to handle this.

Your battery is being drained as your cpu is always on. The reason for cpu when moving mouse is because you are using vesa driver, which uses cpu to draw the pointer. The reason for more drain when on ACPI is because it fails to setup your hardware (IRQ fail in log) which is most likely wrong data in ACPI table. When you are on battery ACPI most likely lower cpu speed, which on such ancient system with no hardware mouse will feel slow. As the clock on your cpu is probably the old type that count different depending on cpu speed, which we don't support as it is so old.

I speak of experience, the first iterations of hardware with ACPI was horrible. I just say that spending time on ancient machines are a waste of my time, and now that I explained just a few of the problems with that machine can you please accept that you will never fully be able to appreciate Haiku on it, unless you want to write and maintain the code for your cpu and your broken ACPI tables yourself.. Look at linux bootlogs if you want to see the fixups it does for your hardware... But please let me focus on newer hardware instead of explaining more about this.

comment:18 by tqh, 22 months ago

Also as far as I remember I didn't fix and enable ACPI until after alpha 4.

comment:19 by Giova84, 22 months ago

I use the vesa driver because I blacklisted the intel driver, to test vesa only.
In the releases notes of Alpha 4 https://www.haiku-os.org/get-haiku/release-notes/ is reported

Haiku's ACPI support, which is enabled by default, might cause problems on some hardware. ACPI can be disabled in the boot loader's safe mode options menu.

This laptop also have the support For Windows 7: https://www.sony.co.uk/electronics/support/laptop-pc-vgn-series/vgn-fs215e

Months ago I also tried Windows 7 on this laptop: if the firmware was broken, I expected to encounter troubles also on Windows Seven: I uninstalled it because the hardware is old and 7 didn't runs wells.

you will never fully be able to appreciate Haiku on it

You can't speak for me. Haiku, here (with ACPI disabled) Haiku runs very well, much better than any other operating system which I had; I also have new (original) battery and new HDD.

I just say that spending time on ancient machines are a waste of my time

So, feel free to close this ticket as invalid, since you said that my firmware is broken, where is the problem? I still enjoy Haiku. I'm ok with "we can't/won't support old hardware" as I'm ok with "I don't want to waste my time", this is an open project mainly based on Volunteering, but there are better ways to talk to people.

Last edited 22 months ago by Giova84 (previous) (diff)

comment:20 by Giova84, 22 months ago

Your battery is being drained as your cpu is always on

Well, with ACPI disabled is not drained. But, however, I don't want to trigger a quarrel with you. I will keep to enjoy Haiku :-)

comment:21 by tqh, 22 months ago

Resolution: no change required
Status: newclosed

I'm not trying to quarrel, I'm just saying that your machine is so old that several features that make Haiku enjoyable is not working. ACPI will probably never work for you as it fails to setup hardware correctly, your cpu can't keep time while frequency scaling, and it will not pause when idle, making it use power even when doing nothing. I rather support new hardware than try to fix machines who lack things we now take for granted and who would need special handling. That way your next computer may be better supported...

Closing this with the remark that it is a known problem on old machines (I looked at a lot of similar things), but not worth pursuing as new machines don't have these kind issues.

comment:22 by Giova84, 22 months ago

hat way your next computer may be better supported...

I also have a "next" computer, but I also enjoy older computers.

I state again that I don't want to quarrel, so I ask you seriously (since you are a developer of the project): so, soon, Haiku will drop gcc2h (32 bit) in favour of x86_64 (64 bit)?

comment:23 by tqh, 22 months ago

Afaik nothing is decided regarding that. Big decisions like that would be in the news section and on the mailing lists. Personally I'd vote for dropping it as I need to maintain ACPI on both platforms and also with several different gcc's. So a lot of rebooting and testing before I even can commit any bigger changes.

comment:24 by Giova84, 22 months ago

Ok, I can understand your point of view. To be exhaustive and friendly, I thought, however, that the powerness of Haiku was (and certainly currently - also - is) the ability to give new life to older computers. Here I have various machine (laptops and desktops) modern and older; my job is about "user assistance", to most of them (nowadays older computers are still present) I introduced Haiku and his magnificient ability to run well also on old hardware. Believe me: also without ACPI enabled, Haiku is amazingly fast on this laptop; on my modern computers is a thunderbolt.
I didn't want to be right; I also waited for other developers to join this discussion, waiting for their opinions about this issue which I found; I'm not egoist: I open ticket and report bugs and enhancements to collaborate as I can to this project.

I'm sorry if you are angry about the discussion which we had (I didn't claim that you have must resolve this ticket), but we should also think for those which aren't aware of this platform: can you consider to reopen this ticket ad assign it to nobody? Maybe someone else (developer) will take the ownership in future of this ticket.

comment:25 by tqh, 22 months ago

I am in not angry. In fact I am thankful for the bugs reported. I'm just saying that this can not be supported properly. However you did ask for a thorough analysis which given my knowledge I will not do. Sorry if my wording was too blunt. I just wanted to close the matter quickly. Afaik no other developers know about ACPI that well or have worked on many ACPI related bugs. I even tried to lure others in...

I will not reopen the issue, I am pretty sure that your hardware is special, and cannot be handled by ACPI properly without writing code for handling old Sony computers. Can you please accept this answer, I do not want to reiterate this more.

comment:26 by Giova84, 22 months ago

Hi, I premise that I don't writing to ask you to reopen this ticket, is just for the sake of completeness.

Today I updated HAIKU, since I've see your commits about ACPI (on http://cgit.haiku-os.org/haiku/log/). After pkgman full, I re-enabled ACPI in the kernel setting file; at the next reboot, by detach the power plug, I notice that Haiku didn't behaves as before: the clock and system doesn't go slow.

However when I do cat /dev/power/acpi_battery/0

I just get:

Battery Status:
 State -856678792, Current Rate 2, Capacity 24576, Voltage 0

Battery Info:
 Power Unit -2146861369, Design Capacity -247452348, Last Full Charge 0, Technology -2092606888
 Design Voltage 12934, Design Capacity Warning -247452432, Design Capacity Low -247452432, Capacity Granularity1 -2145421536, Capacity Granularity1 -2145421536
 Model Number x, Serial Number x, Type XZE<-@8x, OEM Info xZE

And PowerStatus app doesn't start at all.

When I opened this ticket I was able to see battery's infos from Terminal and PowerStatus.

Believe me: I'm not saying this to convince you to reopen this ticket or fix these things, I repeat that is just for sake of completeness about which I said previously, and to point out that your commits have at least solved some issues which I've found.

comment:27 by tqh, 22 months ago

Yes, I also know why, there was an incorrect ACPICA update that disabled all synchronization between hardware and OS, this causes it to use a lot of CPU as it will always run without waiting when it should. Please report other issues in new bugs. Following bug reporting etiquette is important as it makes the developers job much easier. There is already one opened for battery info. See #13920

Note: See TracTickets for help on using tickets.