Opened 16 months ago

Closed 3 months ago

#13917 closed task (fixed)

Building haiku_loader.efi fails because of missing zlib.h

Reported by: tqh Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: System/Boot Loader Version: R1/Development
Keywords: easy uefi Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When building haiku_loader.efi directly after configure, it fails with missing zlib.h. After doing a Haiku builds it works, most likely because the build package for zlib has been downloaded. Add the dependency for zlib for efi.

Hint:

git grep "efi " and git grep "zlib " in build/ directory

Commands to reproduce in a new haiku dir (with no generated dir):

./configure --build-cross-tools x86_64 {buildtools-dir}

jam -j1 -q -sHAIKU_BOOT_PLATFORM=efi haiku_loader.efi

Change History (2)

comment:1 Changed 16 months ago by tqh

Not sure it is a real problem as it built fine now. Maybe it's only a problem if you are doing -j2 or higher. It seems another part (tarfs) downloaded zlib.h before the error could occur.

Last edited 16 months ago by tqh (previous) (diff)

comment:2 Changed 3 months ago by waddlesplash

Resolution: fixed
Status: newclosed

This dependency issue appears to have been solved; at least I have not seen it in quite a long time, and -j16 builds succeed for the most part.

Note: See TracTickets for help on using tickets.