Opened 20 months ago

Closed 5 months ago

Last modified 4 months ago

#13919 closed bug (fixed)

Webpositive crashes loading files on google drive

Reported by: HAL Owned by: pulkomandy
Priority: normal Milestone:
Component: Applications/WebPositive Version:
Keywords: Cc: HAL
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Loading any file on google drive causes a segmentation fault with webpositive.

  1. Login to your google drive account.
  2. Click on any file, eg, a video or photo.

Result: Webpositive crashes. I was testing in hrev51724 x86_64

Attachments (3)

WebPositive-923-debug-01-01-2018-10-15-30.report (35.8 KB ) - added by HAL 20 months ago.
Crash trying to open photo on google drive
WebPositive-1923-debug-01-01-2018-10-33-32.report (25.5 KB ) - added by HAL 20 months ago.
Trying to open video on google drive
WebPositive-2239-debug-01-01-2018-11-00-56.report (24.9 KB ) - added by HAL 20 months ago.
Segmentation fault with webpositive just logged in to google drive

Download all attachments as: .zip

Change History (12)

by HAL, 20 months ago

Crash trying to open photo on google drive

comment:1 by HAL, 20 months ago

Has a Patch: set

by HAL, 20 months ago

Trying to open video on google drive

comment:2 by HAL, 20 months ago

Even just been logged in to google drive will cause Webpositive to crash after about a minute. Version 1.1 alpha, HaikuWebKit 1.6.3 WebKit 602.1.26

comment:3 by humdinger, 20 months ago

Has a Patch: unset

comment:4 by humdinger, 20 months ago

Component: WebsiteApplications/WebPositive
Has a Patch: set
Keywords: Webpositive google drive crash segmentation fault removed
Owner: changed from haiku-web to pulkomandy
Priority: highnormal

by HAL, 20 months ago

Segmentation fault with webpositive just logged in to google drive

comment:5 by pulkomandy, 20 months ago

Has a Patch: unset

comment:6 by waddlesplash, 5 months ago

Still an issue?

comment:7 by humdinger, 5 months ago

Works for me with haikuwebkit 1.6.9 and hrev53047, 32bit.

comment:8 by waddlesplash, 5 months ago

Resolution: fixed
Status: newclosed

Sounds good then.

comment:9 by HAL, 4 months ago

Sorry for seeing this resolution so late but the bug still happens for me. I just tried opening a video on google drive with hrev53092 x86_64 and HaikuWebKit 1.6.9 WebKit 608.1.6. With the google drive video preveiwer app opened, clicking on the start arrow, nothing happened. Waited a while then clicked again still nothing. Clicked again and waited a bit then the whole OS went into KDL with a contuous nonstop pagescrolling output. I could not do anything with the KDL screen so had to push the reset button on my computer. The KDL text line was repeating with:

Failed to set attr: none: DW_AT_abstract_origen, form: DW_FORM_ref4: Bad data

Last edited 4 months ago by HAL (previous) (diff)
Note: See TracTickets for help on using tickets.