Opened 12 years ago

Closed 11 years ago

#1398 closed bug (duplicate)

PANIC: vnode is not becoming unbusy!

Reported by: korli Owned by: axeld
Priority: normal Milestone: R1
Component: File Systems/BFS Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

It happened while net booting with hrev21964.

bfs: bfs_access:1314: Operation not allowed Last message repeated 2 times. bfs: bfs_access:1314: Operation not allowed Last message repeated 3 times. Last message repeated 5 times. PANIC: vnode 4:198406 is not becoming unbusy!

Welcome to Kernel Debugging Land... Running on CPU 0 kdebug> sc stack trace for thread 0x56 "TrackerTaskLoop"

kernel stack: 0x81023000 to 0x81027000

user stack: 0x70000000 to 0x70040000

frame caller <image>:function + offset 81026990 (+ 36) 80082de2 <kernel>:invoke_command + 0x006c 810269b4 (+ 48) 80082ef8 <kernel>:kernel_debugger_loop + 0x00d3 810269e4 (+ 32) 80083952 <kernel>:kernel_debugger + 0x00af 81026a04 (+ 176) 8008389b <kernel>:panic + 0x002d 81026ab4 (+ 64) 80046f12 <kernel>:_Z9get_vnodelxPP5vnodei + 0x01a4 81026af4 (+ 48) 80047bec <kernel>:get_vnode + 0x001a 81026b24 (+ 112) 81607992 <bfs>:_ZN5Inode12GetAttributeEPKcPPS_ + 0x019c 81026b94 (+ 48) 816051fa <bfs>:_ZN9Attribute3GetEPKc + 0x017a 81026bc4 (+ 48) 81605246 <bfs>:_ZN9Attribute4OpenEPKciPP11attr_cookie + 0x003c 81026bf4 (+ 96) 816148d6 <bfs>:_Z13bfs_open_attrPvS_PKciPS_ + 0x0030 81026c54 (+ 80) 8004aca7 <kernel>:_Z9attr_openiPKcib + 0x006f 81026ca4 (+ 288) 8004ad7b <kernel>:_user_open_attr + 0x0049 81026dc4 (+ 352) 8003820a <kernel>:syscall_dispatcher + 0x0c9f 81026f24 (+ 128) 8008b8bf <kernel>:i386_handle_trap + 0x0308 iframe at 0x81026fac (end = 0x81027000)

eax 0x58 ebx 0x695458 ecx 0x80000005 edx 0x424087 esi 0x1801b0a0 edi 0x7003f988 ebp 0x7003f92c esp 0x81026fdc eip 0xffff0102 eflags 0x202 vector: 0x63, error code: 0x0

81026fa4 (+ 0) ffff0102 7003f92c (+ 48) 003c7585 </boot/beos/system/lib/libbe.so@0x00245000>:unknown + 0x182585 7003f95c (+ 64) 003c8c19 </boot/beos/system/lib/libbe.so@0x00245000>:unknown + 0x183c19 7003f99c (+ 800) 00551811 </boot/beos/system/lib/libtracker.so@0x0047c000>:unknown + 0xd5811 7003fcbc (+ 96) 00551ebb </boot/beos/system/lib/libtracker.so@0x0047c000>:unknown + 0xd5ebb 7003fd1c (+ 48) 00552063 </boot/beos/system/lib/libtracker.so@0x0047c000>:unknown + 0xd6063 7003fd4c (+ 48) 005524c0 </boot/beos/system/lib/libtracker.so@0x0047c000>:unknown + 0xd64c0 7003fd7c (+ 96) 0055257c </boot/beos/system/lib/libtracker.so@0x0047c000>:unknown + 0xd657c 7003fddc (+ 272) 00559566 </boot/beos/system/lib/libtracker.so@0x0047c000>:unknown + 0xdd566 7003feec (+ 112) 00559993 </boot/beos/system/lib/libtracker.so@0x0047c000>:unknown + 0xdd993 7003ff5c (+ 32) 0055a15f </boot/beos/system/lib/libtracker.so@0x0047c000>:unknown + 0xde15f 7003ff7c (+ 32) 0059f5aa </boot/beos/system/lib/libtracker.so@0x0047c000>:unknown + 0x1235aa 7003ff9c (+ 32) 0059f361 </boot/beos/system/lib/libtracker.so@0x0047c000>:unknown + 0x123361 7003ffbc (+ 32) 0061e94e </boot/beos/system/lib/libroot.so@0x005fd000>:unknown + 0x2194e 7003ffdc (+ 0) 7003ffec 856:TrackerTaskLoop_56_stack@0x70000000 + 0x3ffec

Change History (5)

comment:1 by korli, 12 years ago

Cc: axeld added

comment:2 by axeld, 12 years ago

Cc: axeld removed
Owner: changed from bga to axeld

This looks like a GCC 4 build. Can you reproduce the problem using GCC 2 as well? Also, does it happen everytime, or only rarely? I'm afraid I can't do a lot about this if I can't reproduce it here.

comment:3 by korli, 12 years ago

In fact, it's a GCC4 build : my GCC2 has to be rebuilt to work with the pxe boot loader assembler code. I'll do this when I have time ...

comment:4 by korli, 12 years ago

Not exactly the same with GCC2:

PANIC: vnode 4:198344 is not becoming unbusy!

Welcome to Kernel Debugging Land... Running on CPU 0 kdebug> bt stack trace for thread 0x54 "TrackerTaskLoop"

kernel stack: 0x81023000 to 0x81027000

user stack: 0x70000000 to 0x70040000

frame caller <image>:function + offset 81026b60 (+ 52) 80089988 <kernel>:invoke_command + 0x0074 81026b94 (+ 48) 80089aa6 <kernel>:kernel_debugger_loop + 0x00de 81026bc4 (+ 32) 8008a532 <kernel>:kernel_debugger + 0x00b2 81026be4 (+ 192) 8008a475 <kernel>:panic + 0x0029 81026ca4 (+ 48) 800457d1 <kernel>:get_vnodeFlxPP5vnodei + 0x0069 81026cd4 (+ 64) 80049d40 <kernel>:fix_direntFP5vnodeP6dirent + 0x00b0 81026d14 (+ 48) 80049e11 <kernel>:dir_readFP5vnodePvP6direntUlPUl + 0x0069 81026d44 (+ 64) 80049c86 <kernel>:dir_readFP15file_descriptorP6direntUlPUl + 0x0026 81026d84 (+ 48) 80044a99 <kernel>:_user_read_dir + 0x0065 81026db4 (+ 336) 80036968 <kernel>:syscall_dispatcher + 0x0b64 81026f04 (+ 160) 80092cc0 <kernel>:i386_handle_trap + 0x02b0 iframe at 0x81026fac (end = 0x81027000)

eax 0x67 ebx 0x4bec78 ecx 0x7003fe58 edx 0x4d0880 esi 0x7003fc80 edi 0x7003fe58 ebp 0x7003fc4c esp 0x81026fdc eip 0xffff0102 eflags 0x246 vector: 0x63, error code: 0x0

81026fa4 (+ 0) ffff0102 7003fc4c (+ 336) 003e3b32 </boot/beos/system/lib/libbe.so@0x0024b000>:unknown + 0x198b32 7003fd9c (+ 272) 005eabed </boot/beos/system/lib/libtracker.so@0x004d5000>:unknown + 0x115bed 7003feac (+ 112) 005eaf61 </boot/beos/system/lib/libtracker.so@0x004d5000>:unknown + 0x115f61 7003ff1c (+ 48) 005eb212 </boot/beos/system/lib/libtracker.so@0x004d5000>:unknown + 0x116212 7003ff4c (+ 48) 00635f73 </boot/beos/system/lib/libtracker.so@0x004d5000>:unknown + 0x160f73 7003ff7c (+ 48) 00635db8 </boot/beos/system/lib/libtracker.so@0x004d5000>:unknown + 0x160db8 7003ffac (+ 48) 006dd7cc </boot/beos/system/lib/libroot.so@0x006bd000>:unknown + 0x207cc 7003ffdc (+ 0) 7003ffec 898:TrackerTaskLoop_54_stack@0x70000000 + 0x3ffec

comment:5 by axeld, 11 years ago

Resolution: duplicate
Status: newclosed

This seems to be a duplicate of #2400 (or rather the other way around, but that seems to have more info.

Note: See TracTickets for help on using tickets.