Opened 12 years ago

Closed 12 years ago

#1399 closed bug (duplicate)

Files corrupted after restart of the system.

Reported by: bbjimmy Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Files corrupted after restart of the system:

To reproduce:

Install an executable file on a new install of Haiku.

Execute the file

Reboot the system [feather] [Restart]

the newly installed program is now no longer executable.

To avoid the corruption:

Install an executable file on a new install of Haiku.

reboot [feather][Restart]

execute the file... no corruption... restart again... no corruption.

summary:

The new file is corrupted if it is executed before a Restart. If it is not executed until after a Restart the file is not corrupted and can be executed any number of times.

( simple quick test ... http://216.110.210.251/fatelk/TextSaver.zip unzip copy TextSaver /boot/home/config/add-ons/Screen Savers/ execute the screensaver THEN reboot.

now the TextSaver file in /boot/home/config/add-ons/Screen Savers/ does not match the file in the TextSaver folder.

re-copy the file and Restart THEN execute the file ... now the system can re-boot and the file is not corrupted.

NOTE: the corruption is not limited to screensavers, this is just a quick test case)

Change History (1)

comment:1 by axeld, 12 years ago

Component: - GeneralSystem/Kernel
Resolution: duplicate
Status: newclosed

This seems to be a duplicate of bug #1369.

Note: See TracTickets for help on using tickets.