Opened 19 months ago

Closed 3 weeks ago

#14018 closed bug (fixed)

Pootle translations not making it to the nightly builds

Reported by: T.Knez Owned by: nielx
Priority: normal Milestone:
Component: Website/Pootle Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

After correcting some of the Swedish translations last thursday (1 March) at the Haiku Pootle site, I noticed that they never made it to the latest nightly release. Something might be broken in the Pootle export or the git import process.

See logs here: https://git.haiku-os.org/haiku/log/?qt=author&q=automatic

Change History (10)

comment:2 by T.Knez, 19 months ago

Yes, they are! Just updated my system and my changes are there now. Thanks!

comment:3 by nielx, 19 months ago

The issue was caused by a caching issue. Pootle only updates the underlying filesystem if the translations are newer than the file on disk. During the test migration, I already noticed that there was something off about writing back new translations to disk. I solved that by doing a one time forced synchronisation. After that, the sync with the disk seemed to work normally.

The automated synchronization failed yesterday, because the files were not updated on disk, and as such there were no new translations to be uploaded.

I will close this ticket for now. Please do reopen if next Saturday new translations do not seem to be uploaded to the repository.

comment:4 by nielx, 19 months ago

Resolution: fixed
Status: newclosed

comment:5 by T.Knez, 19 months ago

I sure will. Thanks again.

comment:6 by T.Knez, 19 months ago

Resolution: fixed
Status: closedreopened

I'm sorry to report that translations didn't get updated from Pootle this saturday either.

comment:7 by nielx, 19 months ago

The Saturday script now always force overwrites the files on disk.

comment:8 by nielx, 19 months ago

Resolution: fixed
Status: reopenedclosed

comment:9 by T.Knez, 16 months ago

Resolution: fixed
Status: closedreopened

The translations are not making it to the nightly again. I made some changes a week ago and they havent been pushed to the nightly yet.

comment:10 by nielx, 3 weeks ago

Resolution: fixed
Status: reopenedclosed

If a language is part of our exports, the strings will be exported weekly (Saturday 08:00 AM UTC) by our translation services. See this commit in our infrastructure repository

Note: See TracTickets for help on using tickets.