Opened 17 months ago

Closed 17 months ago

Last modified 17 months ago

#14019 closed bug (duplicate)

Expander crash after doublclick on zip file

Reported by: lelldorin Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: File Systems/FAT Version: R1/Development
Keywords: Expander Cc:
Blocked By: #7121 Blocking:
Has a Patch: no Platform: x86

Description

I update my Haiku to Hrev 51833. Then i select a zip file (on BFS), Expander crashed and i am in the "Kernel Debugging Land".

I does not know how to close the white window, so i ever need to reboot. I create a screenshot of the error (see attachment).

Attachments (1)

2018-03-05_Expander_Crash_Hrev51833.jpg (299.0 KB) - added by lelldorin 17 months ago.
screenshot

Download all attachments as: .zip

Change History (6)

Changed 17 months ago by lelldorin

screenshot

comment:1 Changed 17 months ago by korli

Component: - GeneralFile Systems/FAT

Expander tries to open a directory on a FAT volume.

Is your FAT volume not corrupt? (just to be sure)

comment:2 Changed 17 months ago by diver

Blocked By: 7121 added
Resolution: duplicate
Status: newclosed

Dupe of #7121.

comment:3 Changed 17 months ago by lelldorin

I have tried from FAT and BeFS, on booth the system crashed.

Why is this report a duplicate? I'm not talking about Paladin here, but about opening a zip file. Even if the error message is similar (BUG Report attachment), it does not have to be the same?

comment:4 Changed 17 months ago by diver

It is the same bug because the panic assert is the same.

comment:5 Changed 17 months ago by korli

In your case, it's not important which file you open, Expander tries on start-up to set its filepanel to a directory on the FAT volume.

Note: See TracTickets for help on using tickets.