#14148 closed bug (fixed)

Marvell 88E8040 Ethernet cuts out in hrev51939

Reported by: BeDifferent1 Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Drivers/Network/marvell_yukon Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86-64

Description

I've been having this issue with the installation of hrev51939 on my Dell Inspiron 1545 with Marvell 88E8040 onboard Ethernet. I haven't tried to reproduce it with the latest (hrev51942), but I'll try it as soon as possible. The issue is, I'm trying to install the broadcom43xx firmware for my WiFi card, and I can only do that if I have a working Ethernet connection; whenever I try to do anything whatsoever with that connection, there seems to be a bug in the network manager that makes it lose its IP address and be apparently unable to re-acquire it. In other words, the network manager's status messages alternate between "No Link" and "Configuring". I'd appreciate it if this were fixed in an upcoming hrev, because it's preventing me from installing my WiFi firmware, as stated above.

Attachments (1)

syslog (136.8 KB ) - added by BeDifferent1 17 months ago.
Syslog from Haiku's /var/log

Download all attachments as: .zip

Change History (7)

comment:1 by diver, 17 months ago

Component: Network & InternetDrivers/Network/marvell_yukon

Please attach your syslog.

comment:2 by korli, 17 months ago

The driver wasn't yet updated to R11.1, see https://git.haiku-os.org/haiku/log/src/add-ons/kernel/drivers/network/marvell_yukon The changes to take over would be from https://svnweb.freebsd.org/base/release/11.1.0/sys/dev/msk/?view=log from revision 267363 to release.

by BeDifferent1, 17 months ago

Attachment: syslog added

Syslog from Haiku's /var/log

comment:3 by BeDifferent1, 17 months ago

If I knew how to change the necessary bits of code in the FreeBSD driver, I would do so... Thanks to korli for clarifying what the issue probably is. In the meantime, I added a copy of my Haiku syslog, hope that helps with any diagnostics. If needed, I can also add syslog.old from /var/log; that might provide more information on the problem.

Last edited 17 months ago by BeDifferent1 (previous) (diff)

comment:4 by korli, 17 months ago

The driver is now updated in hrev51946.

comment:5 by BeDifferent1, 17 months ago

I can confirm that my Marvell 88E8040 Ethernet is now working properly in hrev51972.

comment:6 by korli, 17 months ago

Resolution: fixed
Status: newclosed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.