Opened 2 years ago

Closed 2 months ago

#14147 closed bug (fixed)

Streaming videos not playing; out of memory error (regression)

Reported by: vidrep Owned by: nobody
Priority: normal Milestone: R1/beta2
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #14224
Platform: All

Description

hrev51932 x86_gcc2h

Streaming content that used to play before is now giving a out of memory error.

I ran BePodder from terminal and attached the session log.

Attachments (6)

BePodder.txt (689 bytes ) - added by vidrep 2 years ago.
Download_stream.txt (1.2 KB ) - added by vidrep 2 years ago.
Podcast_error_athleanx.txt (1.3 KB ) - added by vidrep 2 years ago.
wget_URL_athleanx.txt (832 bytes ) - added by vidrep 2 years ago.
terminal_52138.txt (297 bytes ) - added by vidrep 2 years ago.
terminal_52174.txt (2.4 KB ) - added by vidrep 2 years ago.

Download all attachments as: .zip

Change History (18)

by vidrep, 2 years ago

Attachment: BePodder.txt added

comment:1 by vidrep, 2 years ago

Downloading the stream to my desktop and opening MediaPlayer from the terminal allows the video to play normally. Download_stream.txt attached.

by vidrep, 2 years ago

Attachment: Download_stream.txt added

comment:3 by vidrep, 2 years ago

Blocking: 14224 added

comment:4 by vidrep, 2 years ago

Tried again today using hrev52058 x86_gcc2h. I have attached a terminal log as well as a wget of the URL in question (which downloads and plays fine from HDD but does not stream).

by vidrep, 2 years ago

Attachment: Podcast_error_athleanx.txt added

by vidrep, 2 years ago

Attachment: wget_URL_athleanx.txt added

comment:5 by vidrep, 2 years ago

Owner: changed from nobody to Barrett
Status: newassigned

I assigned to Barret, if he doesn't mind having a look, since it's his code which allows BePodder to stream the podcasts.

comment:6 by vidrep, 2 years ago

Updating to hrev52174 has fixed the "out of memory" error, and the video now plays. However, it does so without any audio. Running MediaPlayer from terminal gives the following output before/after update.

Last edited 2 years ago by vidrep (previous) (diff)

by vidrep, 2 years ago

Attachment: terminal_52138.txt added

by vidrep, 2 years ago

Attachment: terminal_52174.txt added

comment:7 by korli, 15 months ago

Owner: changed from Barrett to nobody

comment:8 by waddlesplash, 14 months ago

Still the same behavior?

comment:9 by vidrep, 14 months ago

Yes, still the same

comment:10 by vidrep, 2 months ago

I tested the described URL and several more from the same podcast using hrev54138 x86_64. It works perfectly on 64 bit. I'll update and test on 32 bit to see if the problem is x86_gcc2h specific.

comment:11 by vidrep, 2 months ago

Confirmed working now on 32 bit as well (hrev54138 x86_gcc2h). Is is worth the effort to track down which commit FIXED the problem?

comment:12 by pulkomandy, 2 months ago

Milestone: UnscheduledR1/beta2
Resolution: fixed
Status: assignedclosed

No, we're happy enough to know that the problem is gone :)

Note: See TracTickets for help on using tickets.