#14173 closed bug (fixed)

buildtools: error creating cross-compiler for x86 on x86_64

Reported by: nielx Owned by: waddlesplash
Priority: normal Milestone: Unscheduled
Component: Build System Version: R1/Development
Keywords: Cc: KapiX
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I am trying to build a cross-compiler for x86 on a x86_64 machine. I run into the error that it complains I should recompile with -fPIC. This is with the most recent gcc 7-based buildtools.

See the screenshot for the full message.

Attachments (1)

VirtualBox_Haiku x86_64_29_05_2018_22_04_25.png (143.9 KB ) - added by nielx 17 months ago.

Download all attachments as: .zip

Change History (7)

comment:1 by nielx, 17 months ago

Owner: changed from bonefish to waddlesplash
Status: newassigned

comment:2 by nielx, 17 months ago

I stumbed on this commit on a previous version. Some parts of the linker scripts are not in the current incarnation.

comment:3 by waddlesplash, 17 months ago

Cc: KapiX added

I think that commit was at least partially reverted...?

Anyway, it looks like this was an issue on 5.4 also: https://github.com/haiku/webkit/pull/4

CC'ing KapiX for his input.

comment:4 by KapiX, 17 months ago

Nope, I didn't see that on 5.4. From the beginning I was building with 7.3.

I'm not so sure about LINK_SPEC being the issue anymore though. It needs more in-depth debug. The commit nielx linked could be the solution.

EDIT clarification: I didn't even try building with 5.4, so I don't know if the issue reproduces there.

Last edited 17 months ago by KapiX (previous) (diff)

comment:5 by waddlesplash, 17 months ago

OK, so this may very well be my fault.

I think the commit nielx links was partially reverted due to #12451. I'm not sure how -fpic isn't being passed anymore. I'll have some time this weekend, I guess.

Last edited 17 months ago by waddlesplash (previous) (diff)

comment:6 by waddlesplash, 17 months ago

Resolution: fixed
Status: assignedclosed

Fixed in btrev43128 and btrev43129.

Note: See TracTickets for help on using tickets.