#14178 closed bug (fixed)

Webpositive Crashes from Haiku Home Webpage

Reported by: HAL Owned by: pulkomandy
Priority: normal Milestone:
Component: Website/Forums Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86-64

Description

Clicking Forums on www.haiku-os.org causes crash. This is reproduceable 100%. Happens in hrev51921 x86_64

Attachments (4)

WebPositive.tar.xz (148.5 KB) - added by kallisti5 14 months ago.
compressed due to size
WebPositive-1068-debug-02-06-2018-00-20-33.report.zip (812.4 KB) - added by HAL 14 months ago.
Saved Report Webpositive crash
WebPositive-1118-debug-12-06-2018-02-46-23.7z (133.4 KB) - added by cocobean 13 months ago.
Webpositive_hrev52001 x86_64 crash with discuss.haiku-os forum website homepage
WebPositive-652-debug-15-06-2018-20-41-02.7z (159.2 KB) - added by cocobean 13 months ago.
Webpositive_hrev52017 x86_64 crash with discuss.haiku-os forum website homepage

Download all attachments as: .zip

Change History (12)

comment:1 Changed 14 months ago by HAL

Attachment for this bug won't upload.

comment:2 Changed 14 months ago by kallisti5

Owner: changed from kallisti5 to pulkomandy
Status: newassigned

yeah, I've seen this as well for discuss.haiku-os.org.

comment:3 Changed 14 months ago by pulkomandy

Without a debug report the ticket is useless, especially as this is probably already fixed in the current testbuilds of haikuwebkit, or even the current release which was not made available for x86_64.

Last edited 14 months ago by pulkomandy (previous) (diff)

Changed 14 months ago by kallisti5

Attachment: WebPositive.tar.xz added

compressed due to size

comment:4 Changed 14 months ago by HAL

I wanted to test on latest build first before reporting this bug but pkgman update would go through seeming to update everything but after reboot it was still at old hrev. So that is why I wanted to go to the forums to ask about this but got this webpositive crash. I also tried to upload the saved report but kept getting message "upload failed". I tried uploading from linux, first mounting haiku partition but the Desktop folder would not show it. I had made sure "show hidden files" was selected in linux nemo. The only other way is for me to copy the saved report onto a usb stick then reboot into linux and upload the file from that.

Changed 14 months ago by HAL

Saved Report Webpositive crash

comment:5 Changed 14 months ago by HAL

I finally got it to upload. The reason why it would not from Haiku probably the file size was too large but did not get any reason why with first tries. Now I did get the reason why so I compressed it.

Changed 13 months ago by cocobean

Webpositive_hrev52001 x86_64 crash with discuss.haiku-os forum website homepage

comment:6 Changed 13 months ago by cocobean

Confirmed on hrev52001 x86_64.

Changed 13 months ago by cocobean

Webpositive_hrev52017 x86_64 crash with discuss.haiku-os forum website homepage

comment:7 Changed 13 months ago by cocobean

Tested: hrev52020 x86_64, HaikuWebkit 1.6.5/Webkit 605.1.17/WebPositive.

https://discuss.haiku-os.org home web page loads and renders successfully.

Clicking Community Forums on www.haiku-os.org loads successfully.

Viewed and read several thread messages. No major issues other than a few missing nagitional icons (see Ticket #14113).

Last edited 13 months ago by cocobean (previous) (diff)

comment:8 Changed 13 months ago by waddlesplash

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.