Opened 2 years ago

Closed 19 months ago

Last modified 4 months ago

#14220 closed bug (fixed)

Regression: Atheros Killer E220x cannot configure network

Reported by: i80and Owned by: nobody
Priority: normal Milestone: R1/beta2
Component: Network & Internet Version: R1/Development
Keywords: DHCP Cc:
Blocked By: Blocking:
Platform: All

Description

I have an Atheros Killer E220x ethernet card which used to work.

I just recently spun up Haiku again after a hiatus, and found that the network never configures. The device is detected, and I can see the TX counter increase as Haiku sends DHCP requests, but the RX counter remains at 0.

Attachments (1)

syslog (417.0 KB ) - added by i80and 2 years ago.

Download all attachments as: .zip

Change History (12)

by i80and, 2 years ago

Attachment: syslog added

comment:1 by waddlesplash, 2 years ago

DHCP is known to be pretty flaky on certain configurations. Try using a static address instead.

comment:2 by waddlesplash, 2 years ago

Looking at the syslog, it looks similar to the DHCP config looping that I've seen elsewhere, but unlike #13789 and friends it never gets any replies from the DHCP server, interesting.

Hmm, actually this looks nearly identical to #14027.

comment:3 by i80and, 2 years ago

Static network configuration yields the same result; pinging my gateway results in "No route to host", and while the Sent byte count increases, the Received byte count stays at zero.

I'll try to bisect the hrev that broke it some time this week.

comment:4 by waddlesplash, 2 years ago

Please retest with a recent nightly; the Atheros driver has been updated.

comment:5 by i80and, 2 years ago

Reproduced on hrev52107, unfortunately.

This actually may not be a regression. Testing hrev50904 shows the same problem, so it's possible something I don't know about has changed in my environment since I initially added support for my card.

comment:6 by waddlesplash, 23 months ago

Keywords: DHCP added

comment:7 by selim, 22 months ago

I had exactly the same problem with atheros E2200. For me it started working after follwing steps:

  1. Turn computer off
  2. Disconnect power for a minute
  3. Boot straight into haiku. (it won't work if you boot into windows or linux first, and then reboot into haiku)

It looks like windows initializes network adapter in such a way, that haiku can't work with it even after reboot (that's my guess, I don't know how it actually works)

comment:8 by waddlesplash, 19 months ago

I wonder if 14b0498cfa is related here, possibly your router choked on the partially-invalid ARP packets we were sending before. So please retest with a recent nightly and see if this is fixed now.

comment:9 by i80and, 19 months ago

Just tried a couple of reboots on the latest nightly build, and my network consistently works again! This issue was sporadic which always made it frustrating to try and reproduce, but I think this can probably be closed.

Thank you!

comment:10 by waddlesplash, 19 months ago

Resolution: fixed
Status: newclosed

Thanks for testing!

comment:11 by nielx, 4 months ago

Milestone: UnscheduledR1/beta2

Assign tickets with status=closed and resolution=fixed within the R1/beta2 development window to the R1/beta2 Milestone

Note: See TracTickets for help on using tickets.